summaryrefslogtreecommitdiff
path: root/app-shells/hstr/hstr-1.24.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/hstr/hstr-1.24.ebuild')
-rw-r--r--app-shells/hstr/hstr-1.24.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-shells/hstr/hstr-1.24.ebuild b/app-shells/hstr/hstr-1.24.ebuild
new file mode 100644
index 000000000000..0f8e9981f2a3
--- /dev/null
+++ b/app-shells/hstr/hstr-1.24.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Shell history suggest box"
+HOMEPAGE="https://github.com/dvorka/hstr http://www.mindforger.com"
+SRC_URI="https://github.com/dvorka/hstr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-fbsd"
+
+RDEPEND="sys-libs/ncurses:0="
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( CONFIGURATION.md README.md )
+
+src_prepare() {
+ default
+ sed \
+ -e 's:-O2::g' \
+ -i src/Makefile.am || die
+ eautoreconf
+}