summaryrefslogtreecommitdiff
path: root/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20230117.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20230117.ebuild')
-rw-r--r--app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20230117.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20230117.ebuild b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20230117.ebuild
new file mode 100644
index 000000000000..5b710a44d1e4
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20230117.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gentoo/gentoo-zsh-completions.git"
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
+
+DESCRIPTION="Gentoo specific zsh completion support (includes emerge and ebuild commands)"
+HOMEPAGE="https://github.com/gentoo/gentoo-zsh-completions"
+
+LICENSE="ZSH"
+SLOT="0"
+
+RDEPEND=">=app-shells/zsh-4.3.5"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+
+ dodoc AUTHORS
+}