summaryrefslogtreecommitdiff
path: root/app-shells/gentoo-bashcomp/gentoo-bashcomp-20140911.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/gentoo-bashcomp/gentoo-bashcomp-20140911.ebuild')
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20140911.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20140911.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20140911.ebuild
new file mode 100644
index 000000000000..de1290e2a58b
--- /dev/null
+++ b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20140911.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="Gentoo-specific bash command-line completions (emerge, ebuild, equery, etc)"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
+IUSE=""
+
+src_install() {
+ emake DESTDIR="${D}" install \
+ completionsdir="$(get_bashcompdir)" \
+ helpersdir="$(get_bashhelpersdir)" \
+ compatdir="${EPREFIX}/etc/bash_completion.d"
+}