summaryrefslogtreecommitdiff
path: root/app-shells/dash/dash-0.5.11.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/dash/dash-0.5.11.2.ebuild')
-rw-r--r--app-shells/dash/dash-0.5.11.2.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/app-shells/dash/dash-0.5.11.2.ebuild b/app-shells/dash/dash-0.5.11.2.ebuild
index ea4ee62b3c0a..1299af651db8 100644
--- a/app-shells/dash/dash-0.5.11.2.ebuild
+++ b/app-shells/dash/dash-0.5.11.2.ebuild
@@ -40,6 +40,10 @@ src_configure() {
# if your headers strictly adhere to POSIX, you'll need this too
[[ ${CHOST##*solaris2.} -le 10 ]] && append-cppflags -DNAME_MAX=255
fi
+ if [[ ${CHOST} == powerpc-*-darwin* ]] ; then
+ sed -i -e 's/= stpncpy(s, \([^,]\+\), \([0-9]\+\))/+= snprintf(s, \2, "%s", \1)/' \
+ src/jobs.c || die
+ fi
append-cppflags -DJOBS=$(usex libedit 1 0)
use static && append-ldflags -static
# Do not pass --enable-glob due to #443552.