summaryrefslogtreecommitdiff
path: root/app-shells/bash/bash-5.0_p11-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash/bash-5.0_p11-r1.ebuild')
-rw-r--r--app-shells/bash/bash-5.0_p11-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-shells/bash/bash-5.0_p11-r1.ebuild b/app-shells/bash/bash-5.0_p11-r1.ebuild
index a2adb6b02922..bb06e48ea224 100644
--- a/app-shells/bash/bash-5.0_p11-r1.ebuild
+++ b/app-shells/bash/bash-5.0_p11-r1.ebuild
@@ -46,7 +46,7 @@ fi
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="afs bashlogger examples mem-scramble +net nls plugins +readline"
DEPEND="
@@ -252,7 +252,7 @@ pkg_preinst() {
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.
local target=$(readlink "${EROOT}"/bin/sh)
- local tmp=$(emktemp "${EROOT}"/bin)
+ local tmp="${T}"/sh
ln -sf "${target}" "${tmp}"
mv -f "${tmp}" "${EROOT}"/bin/sh
fi