summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/Manifest.gzbin9753 -> 9757 bytes
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.36.7-r2.ebuild107
-rw-r--r--app-portage/iwdevtools/Manifest2
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.12.14.ebuild70
5 files changed, 180 insertions, 0 deletions
diff --git a/app-portage/Manifest.gz b/app-portage/Manifest.gz
index d69120519e72..4e9dd628d684 100644
--- a/app-portage/Manifest.gz
+++ b/app-portage/Manifest.gz
Binary files differ
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index db03ab3d946d..2c2c2d863dbf 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,3 +1,4 @@
DIST eix-0.36.7.tar.xz 639832 BLAKE2B 37202ae78378688ede95b410fe2e6325d63a9553dc082e4e09dc5bcd261f4e7bf49f349a92c286743c30a54cdc5bc1733fedebae33c37d601e6f5db1faf499e7 SHA512 5f5d059b502633be22c8a18fca410e2319061989bbc65b23592c87a9a109b93e615a5b5a7ca92a500999e3cc791e331b12e32a10700cc104040b1980f7f7a0f9
EBUILD eix-0.36.7-r1.ebuild 2529 BLAKE2B 6e2b60686d17411e16bbc233962e3250398224ed69d0703051c64774cd29ea4071ef3e4404ce5b3a36ae85d566de13fb9da83bf4cf6aa1242299ffdef170144b SHA512 42c966d17db3e9bfcf4c9c65b6a4b7c151d6368cf08f9ca08971472c6a1230c494a6b9cac1f451b0770ed1c8ee05b78e2ccb5f35e4b7a5a96be9c83fe8cad706
+EBUILD eix-0.36.7-r2.ebuild 2610 BLAKE2B 4b5c6536aaaa22d71e15d33410b58dd99abde7595fe63db3ccc5f87308b1936c47855909dcf7eac871ac39e81c858547e33aa48fb7d49d121e9ea73411e9b27d SHA512 c9cf134accb921173b5d9baa4e8609bab44c7d1c709d66ef61a16ed3cf1b73011ea2132237dc5e44841ce0e27e71782364710b4d93fbb1664a1b9dc53b5f4eed
MISC metadata.xml 952 BLAKE2B ef76318a2bef5560870b4c4e48ca3122ccf67f5951f8cd4a5423b6a667a39311c9725aa99a115d18e0035106f4ebc2d2679987feea91c477d5f19d6244f885cd SHA512 823873a3a87bf0ff3cbb8ab6bd2eebdf45b1f5541aa13cd4a1411def808e03b5c961050a6fc10fa5210694fac9736e0acb4917df75e7d238391dffdbb2094cd9
diff --git a/app-portage/eix/eix-0.36.7-r2.ebuild b/app-portage/eix/eix-0.36.7-r2.ebuild
new file mode 100644
index 000000000000..267da33306af
--- /dev/null
+++ b/app-portage/eix/eix-0.36.7-r2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools bash-completion-r1 tmpfiles
+
+DESCRIPTION="Search and query ebuilds"
+HOMEPAGE="https://github.com/vaeth/eix/"
+SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="debug doc nls sqlite"
+
+DEPEND="
+ nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3:= )"
+RDEPEND="${DEPEND}
+ >=app-shells/push-2.0-r1
+ >=app-shells/quoter-3.0_p2-r1"
+BDEPEND="
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ # remove stale cache file to prevent collisions
+ local old_cache=${EROOT}/var/cache/${PN}
+ if [[ -f ${old_cache} ]]; then
+ rm "${old_cache}" || die
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
+
+ sed -e "/eixf_source=/s:push.sh:cat \"${EPREFIX}/usr/share/push/push.sh\":" \
+ -e "/eixf_source=/s:quoter_pipe.sh:cat \"${EPREFIX}/usr/share/quoter/quoter_pipe.sh\":" \
+ -i src/eix-functions.sh.in || die
+ sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EPREFIX}/usr/share/eix/eix-functions\\\\\":" \
+ -i src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug paranoic-asserts)
+ $(use_enable nls)
+ $(use_with doc extra-doc)
+ $(use_with sqlite)
+ --without-protobuf
+
+ # default configuration
+ $(use_with prefix always-accept-keywords)
+ --with-dep-default
+ --with-required-use-default
+
+ # paths
+ --with-portage-rootpath="${ROOTPATH}"
+ --with-eprefix-default="${EPREFIX}"
+ --with-sh-shebang="${EPREFIX}/bin/sh"
+
+ # build a single executable with symlinks
+ --disable-separate-binaries
+ --disable-separate-tools
+
+ # used purely to control/disrespect *FLAGS
+ --disable-debugging
+ --disable-new_dialect
+ --disable-optimization
+ --disable-strong-optimization
+ --disable-security
+ --disable-nopie-security
+ --disable-strong-security
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ dotmpfiles tmpfiles.d/eix.conf
+
+ dosym -r /usr/bin/eix-postsync /etc/portage/postsync.d/50-eix-postsync
+
+ rm -r "${ED}"/usr/bin/eix-functions.sh || die
+}
+
+pkg_postinst() {
+ tmpfiles_process eix.conf
+
+ local obs=${EROOT}/var/cache/eix.previous
+ if [[ -f ${obs} ]]; then
+ ewarn "Found obsolete ${obs}, please remove it"
+ fi
+}
+
+pkg_postrm() {
+ if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
+ rm -rf "${EROOT}/var/cache/${PN}" || die
+ fi
+}
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index 2a640a99d6e5..19d6202a7c8d 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1,4 +1,6 @@
DIST iwdevtools-0.12.13.tar.gz 92069 BLAKE2B aab815edc3a8ba5e57cac7954af3bbb75e66ca605ea0299c5d024fcaf321fe0d00b1b2fb1a22178ab485de1c669220c845ec9b69c94f22ffd925d347b737c47b SHA512 20a3b238fd27d7c57faf2f79705d86359f3dde0b8e59bd4fa63844aea294d539a74a875916a5129f4a774edc9e26b485a5852393f450edb74894f43d5c1cc3a1
+DIST iwdevtools-0.12.14.tar.gz 92477 BLAKE2B ed7291fd686400369a9a9ed8e8a35b310905a494486e65ee98787a746677e744b93070f0f6ebffee72d1da49297ab9c389e40207db1c318e47684bf2d44aef60 SHA512 06525fff14487619a4a7743d53ad49d904922fc955ea7f8d848f97818bb24ca15a56baa29ecb2ff935dc38140ce2e95b126078cf80bbb95c1f6cebd57d1bc6e3
EBUILD iwdevtools-0.12.13.ebuild 1941 BLAKE2B 05a7cffe9f1432cb06e39bf402eded0b38fed268cc4c9a5a48e805157a674913dc701156a48068033c9ace0d70075b9cf74b6072b874cec3ba6bb93452ffd937 SHA512 e58e839455245fa4c2825cf2bb37ea08845d71abc31123d428ab8ee7b8c842a8242f6da52762f869116857e418b9a98a4fe6d3c8ec05c2a8391143f87105578e
+EBUILD iwdevtools-0.12.14.ebuild 1949 BLAKE2B 7be59720bb4e1a78ea24aae83a48d47c32ce4c189af93deaddb9891d2492c9120976b6b9bf8e54197a05af44f4e12028e4de7065aa066264682000062e2c292e SHA512 d027c327cd3c5087b7d01fef1ada45453cd1c6cb229a8b09931e61df10f57b0be9e46af58eb8e05bcfbefb23f3239c0c2d064df3eefc78a4603e662a1e0bc922
EBUILD iwdevtools-9999.ebuild 1828 BLAKE2B 80d91ac38296f1a8cc4696f32c523ef2d5f8bd7bcbdff5bac0790058f36e1c4500a5d807a370f8f8f407735e071fb91d8279bb5d7d542b8c318a0dd74e07d212 SHA512 fd042cc343dd62e315cf7e552543a937c114877bee77c4856046e1d1d93a2d5d35ad0747ec970246eb4af5498fe3727d88ffb1615c081fd7557c43dddef2f6df
MISC metadata.xml 354 BLAKE2B 752c8fbf18967fb380f0f5d460396222f5fea3f0c7b9ed960ff0dbe62a9a505a2d07c45750aaa55285d11169e01f5e83b82eb278b12fbc5e9c43353c0a5fc9ed SHA512 d8e5866d89b7f05a5a8cd8cc464083d3d096b4c03f8a83e9314dcf45e57c25369bf8a3bc725aed3b8db9f3f86e76bad358bfa58f1eca70f7ec0bf3d31286c2c3
diff --git a/app-portage/iwdevtools/iwdevtools-0.12.14.ebuild b/app-portage/iwdevtools/iwdevtools-0.12.14.ebuild
new file mode 100644
index 000000000000..ec44767eee7c
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.12.14.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools/"
+SRC_URI="
+ https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ >=app-shells/bash-5.1:0[readline]
+ dev-libs/libxml2:2
+ sys-apps/coreutils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )
+"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}