summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/Manifest.gzbin9415 -> 9417 bytes
-rw-r--r--app-portage/gemato/Manifest4
-rw-r--r--app-portage/gemato/gemato-18.0.ebuild53
-rw-r--r--app-portage/gemato/gemato-9999.ebuild6
4 files changed, 60 insertions, 3 deletions
diff --git a/app-portage/Manifest.gz b/app-portage/Manifest.gz
index ca76f201378d..191408d6f39d 100644
--- a/app-portage/Manifest.gz
+++ b/app-portage/Manifest.gz
Binary files differ
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index 79c35173c10a..0f1f55e2c08a 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1,4 +1,6 @@
DIST gemato-17.0.tar.gz 83991 BLAKE2B 7a01b8ecb9e3540c698b7d57e5b6ba0961d42e7edd51e7b422d0e3d89088230633f3402b19168b3ccb772f028a3f669b324e76fa84f1918afa1c92c728942f14 SHA512 22066939ccab081c5d2bd52eab587aed0893b11cac40256a2e08a9a2f14e20320acaffd3414c4111bf27db15aca6d76a3856b6a3d8d5019fd649a2f7e07e3265
+DIST gemato-18.0.gh.tar.gz 85575 BLAKE2B a923c3d7731b70798d9baf7e9faf0884723bb5e15b4e24712ecd807b79e8ca7e1532f894cf6a3b675bd72419eac41f1481fcd34fb21c9989871141819b036fa2 SHA512 9491579c3d80f9b500da2a50aed173641d049293e37f11c3c06616ff49949cae16dfd274ae79dcacca4bb4c27baf30a5f3900f45fc3dfb2b9fb5da8139db63e3
EBUILD gemato-17.0.ebuild 1031 BLAKE2B 6b390754cbbedb4d665b98ef29548b18e65b9e1721525b1f7dce2055c909288facc6439aa7f3948475227d84d1da50bc1de5d9cc62065d332af70a6628402776 SHA512 a6237288c3327e58027bef5821bccc0edbc1a4f37b4051b4a4b829b488dc2b3d9bf300420d66f372c67e159bb4d132153f2858bb2f61255de925ad76bf12ada9
-EBUILD gemato-9999.ebuild 930 BLAKE2B dca098f6709cbb3fb413f94e897d9d5ce6924920b14ff4560c86850558c213086e66a77f4fca630024d308b52eaaaafb1566b0e3284227985dcfab7ed47c2549 SHA512 92fb15b26972e8692b07bb51ba22ad9cc10ac2e2c121cf0b7a8d366f6b5467b92a73e79efb5634572536235201f3394641da5c2a1164a5e494a5e2f788e90158
+EBUILD gemato-18.0.ebuild 1114 BLAKE2B c3d5d8f9b1a8034c7799c6f2d413738201cc70f455c101e1647679eb56da50400844277fa68baf58e3a4975d69ae6fbb6dd4bbdda544c55a389b68e40d112f28 SHA512 a8cf5b5443eadf1742877fbc9acf9c5a21b584227d9f8ee1066cf14491044768387859f914ea3bae352ad3a4c6d8d473965178549b5aa7ee9a7219d24b93b35a
+EBUILD gemato-9999.ebuild 957 BLAKE2B 361e57ab1a563727eaaec872d9c427a9935ab5c2863996ae72869a8b6817824f81755ad7fb033ac782a71b09bfdb6c4e8e6290645b3d904647836b4705558ae3 SHA512 9383726e8c7be060b8537477733eb93cece38ed04b375455db0cb907d10647018f9a6021f6fd1e4388f66f6f4c6c80ff192c2e5b7f1e7132e63d99410ea39258
MISC metadata.xml 805 BLAKE2B 039ea9810f2c76d69bdfa5823994be4aa012746032a8c1e01aa7a11a05e4c4e0b278ff5633a519ad8e7398f3328480128c7d9d621dc7911d1ed1d827175c7dac SHA512 1fb3ec26e41b912cdd6ca289acadc50f2d73adf4e9cf9cae40c197ecfa10c19e17716e7153c9be82684ae35580d03ae296586b062f2d54641ab2738c338f1626
diff --git a/app-portage/gemato/gemato-18.0.ebuild b/app-portage/gemato/gemato-18.0.ebuild
new file mode 100644
index 000000000000..7e02cc9bba9d
--- /dev/null
+++ b/app-portage/gemato/gemato-18.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="
+ https://github.com/projg2/gemato/
+ https://pypi.org/project/gemato/
+"
+SRC_URI="
+ https://github.com/projg2/gemato/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="+gpg pretty-log tools"
+
+RDEPEND="
+ gpg? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ pretty-log? (
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}
diff --git a/app-portage/gemato/gemato-9999.ebuild b/app-portage/gemato/gemato-9999.ebuild
index a91d89381cb1..065c894ffff0 100644
--- a/app-portage/gemato/gemato-9999.ebuild
+++ b/app-portage/gemato/gemato-9999.ebuild
@@ -10,8 +10,10 @@ PYTHON_REQ_USE='threads(+)'
inherit distutils-r1 git-r3
DESCRIPTION="Stand-alone Manifest generation & verification tool"
-HOMEPAGE="https://github.com/projg2/gemato"
-SRC_URI=""
+HOMEPAGE="
+ https://github.com/projg2/gemato/
+ https://pypi.org/project/gemato/
+"
EGIT_REPO_URI="https://github.com/projg2/gemato.git"
LICENSE="BSD-2"