summaryrefslogtreecommitdiff
path: root/app-portage/unsymlink-lib/unsymlink-lib-18.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/unsymlink-lib/unsymlink-lib-18.ebuild')
-rw-r--r--app-portage/unsymlink-lib/unsymlink-lib-18.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-portage/unsymlink-lib/unsymlink-lib-18.ebuild b/app-portage/unsymlink-lib/unsymlink-lib-18.ebuild
new file mode 100644
index 000000000000..03c0f831738d
--- /dev/null
+++ b/app-portage/unsymlink-lib/unsymlink-lib-18.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-single-r1
+
+DESCRIPTION="Convert your system to SYMLINK_LIB=no"
+HOMEPAGE="https://github.com/mgorny/unsymlink-lib"
+SRC_URI="https://github.com/mgorny/unsymlink-lib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# tests are docker-based, you need a running docker daemon and you
+# should expect leftover images
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ sys-apps/portage[${PYTHON_MULTI_USEDEP}]
+ ')"
+
+src_install() {
+ python_doscript unsymlink-lib
+ dodoc README
+}