summaryrefslogtreecommitdiff
path: root/app-portage/mgorny-dev-scripts/mgorny-dev-scripts-10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/mgorny-dev-scripts/mgorny-dev-scripts-10.ebuild')
-rw-r--r--app-portage/mgorny-dev-scripts/mgorny-dev-scripts-10.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-portage/mgorny-dev-scripts/mgorny-dev-scripts-10.ebuild b/app-portage/mgorny-dev-scripts/mgorny-dev-scripts-10.ebuild
new file mode 100644
index 000000000000..3aa5c6d2cdf8
--- /dev/null
+++ b/app-portage/mgorny-dev-scripts/mgorny-dev-scripts-10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Handy scripts for ebuild development and more"
+HOMEPAGE="https://github.com/mgorny/mgorny-dev-scripts"
+SRC_URI="https://github.com/mgorny/mgorny-dev-scripts/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-portage/gentoolkit
+ dev-perl/URI
+ dev-util/pkgcheck
+ dev-vcs/git
+ net-misc/wget
+ sys-apps/portage
+ x11-misc/xdg-utils
+ !dev-util/pkgdiff"
+
+src_install() {
+ dodoc README.rst
+ rm -f COPYING README.rst || die
+ dobin *
+}