summaryrefslogtreecommitdiff
path: root/app-portage/kuroo
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/kuroo')
-rw-r--r--app-portage/kuroo/Manifest3
-rw-r--r--app-portage/kuroo/files/kuroo-1.2.1-cmake.patch108
-rw-r--r--app-portage/kuroo/kuroo-1.2.1.ebuild2
3 files changed, 112 insertions, 1 deletions
diff --git a/app-portage/kuroo/Manifest b/app-portage/kuroo/Manifest
index 39de39ce8fbf..62f81eb1e885 100644
--- a/app-portage/kuroo/Manifest
+++ b/app-portage/kuroo/Manifest
@@ -1,4 +1,5 @@
+AUX kuroo-1.2.1-cmake.patch 3239 BLAKE2B c74f9b3bb863a2989d1c994f77ac9161d759adcf1acd2651eaa44d59c6899617e2becdaad4e3eb34723c7b5a68ae450db89371b514677af24b898ba762825e7c SHA512 1b60e48aa1daa611bb06ab0d1b806e15802d80318804037e0730198cd5de95156bc968f6169bbe8fad3bf3458884361a07cbc26fb856bf6fb6938c1a30d4a4bb
DIST kuroo-1.2.1.tar.xz 247540 BLAKE2B 69c8a85cd58347b835039f4bc6929abb71baf517ee1de8b10779d4ba08b997bd46a8e0a5b1c55ea2847d80ab58ed336e524cf53cf707416a6182a0dcbd84abc9 SHA512 3815fcdb27c234669accd3abf0f6f252194d680bc1c18f13e66c428cfcef50685019b19ca8fe20fec1b633e6ed224620cf67eea8a29f593b33760d19657d2d24
-EBUILD kuroo-1.2.1.ebuild 1241 BLAKE2B 69d6e719375fc6a02cb1b21f428e5c08d0f1c0f6b1625493433a132fdc9763c7b3bbaba2c61b88ae580143282fa301a3c3a9ba756b41015469c95cfdf937623f SHA512 9082c45a13951ddafe77a092509f01a11209f32be0d8c25c62a6c2e10dc1bfe48a3e29acf64bee4eef78b7992555adb4625e0adec5f13bf04ae6ff09bf99a96b
+EBUILD kuroo-1.2.1.ebuild 1298 BLAKE2B e314b7e97665cadfd56a0df6076a8beb32d0dbd7d4fdac483fd800aa5722a44ca35e32880dbe12f70bbac990f299e78954f2d50212ac931cb1810318a60fc130 SHA512 9b28b95b91b2eae68e7c50f3627f5c0c262692e86dd5654f5952e4dc90e7020b576e623cc95dbd483a5bb6f0ebbfcd7bbf2397cf48ac00ce4c0e199b4896fe68
EBUILD kuroo-9999.ebuild 1258 BLAKE2B 72c28ae448d8fdb1663951a8928cc3e0f9588b7d2248f9a0b70df5c0be56e08f5af0f36a07a51dd197665de8c75f3bce7a9705e2fd4c4f95936be881e8a6aaa5 SHA512 76c1ef2215f4399abf9eed626c1c8fef5288b41097029402c182f2028c783497a3222bd6ae0f080a362df71ffc894dc611e5540e2fdc411feb5f7fdda46d8a9e
MISC metadata.xml 788 BLAKE2B 948ef576b4bac70a83da4c753b3ae7b4d8d32fdf45c50fdc0a49245f02b3107a8db0dec47c58367d643dd55c8af489159faf714b3800af6b6f47efb912ac7a25 SHA512 9e459ffddff6c2bb515272933af705e23312731ce0466b88e9469ed1d7927301c08dfdb4117f2dc29edf2c8d9b79fe5ce8ed73441a90ecb3adda0546d9dd7c46
diff --git a/app-portage/kuroo/files/kuroo-1.2.1-cmake.patch b/app-portage/kuroo/files/kuroo-1.2.1-cmake.patch
new file mode 100644
index 000000000000..a84a503f7d7d
--- /dev/null
+++ b/app-portage/kuroo/files/kuroo-1.2.1-cmake.patch
@@ -0,0 +1,108 @@
+Drop bogus dependencies, add implicit.
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -11,25 +11,32 @@
+ include(ECMInstallIcons)
+ include(ECMAddTests)
+
+-find_package(Qt5Widgets REQUIRED)
++# Works without this explicit declaration but it ought to be here for correctness
++find_package( SQLite3 REQUIRED )
+
+-find_package( KF5 ${KF5_MIN_VERSION} REQUIRED
+- Auth
+- Config
+- ConfigWidgets
+- CoreAddons
+- I18n
+- IconThemes
+- ItemModels
+- ItemViews
++# These are actually all deps of other things
++find_package( Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS
++ Core
++ Gui
++ Widgets
++)
++
++find_package( KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
++ # These are all required directly and not provided by any dependencies. It "compiles and works" on the development system with just these
+ KIO
+ Notifications
+ ThreadWeaver
+ TextWidgets
+- Su
+- WidgetsAddons
+- WindowSystem
+- XmlGui
++ # Required in link step
++ XmlGui # MainWindow is XmlGuiWindow
++ ItemViews # TreeWidgetSearchLine
++ # These seem to be provided by deps, but should be direct deps too
++ ConfigWidgets
++ I18n # i18n(QStr)
++ Config # Config dialogs
++ Auth # KAuthExecuteJob &c.
++ CoreAddons # AboutData? Job Process User?
++ WidgetsAddons # Font(Chooser|Requester)? PageWidget? MessageBox ...
+ )
+
+ #
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -102,25 +102,37 @@
+ kde_enable_exceptions()
+
+ target_link_libraries( kuroo
++ # These are all used directly and not provided by any other dependency. It "compiles and works" on the development system with just these
++ KF5::KIOCore
++ KF5::Notifications
++ KF5::ThreadWeaver
++ KF5::TextWidgets
++ KF5::XmlGui
++ sqlite3 # TODO: use some sort of ORM maybe find_package?
++ KF5::ItemViews
++ # Builds without these specified, but they should be necessary
+ Qt5::Core
++ Qt5::Gui
++ Qt5::Widgets
+ KF5::Auth
++ KF5::AuthCore
+ KF5::ConfigCore
+ KF5::ConfigGui
++ KF5::ConfigWidgets
+ KF5::CoreAddons
+ KF5::I18n
+- KF5::ItemViews
+- KF5::KIOCore
+- KF5::Notifications
+- KF5::ThreadWeaver
+- KF5::TextWidgets
+ KF5::WidgetsAddons
+- KF5::WindowSystem
+- KF5::XmlGui
+- sqlite3
+ )
+
+ add_executable( kuroo_helper auth/kuroohelper.cpp )
+-target_link_libraries( kuroo_helper Qt5::Core KF5::KIOCore KF5::Auth KF5::CoreAddons )
++target_link_libraries( kuroo_helper
++ # These are all used directly and not provided by any other dependency. It "compiles and works" on the development system with just these
++ KF5::KIOCore
++ KF5::Auth
++ # Builds without explicit declaration, but these make sense
++ Qt5::Core
++ KF5::CoreAddons # KProcess
++)
+ install( TARGETS kuroo_helper DESTINATION ${KAUTH_HELPER_INSTALL_DIR} )
+ kauth_install_helper_files( kuroo_helper org.gentoo.portage.kuroo root )
+ kauth_install_actions( org.gentoo.portage.kuroo auth/org.gentoo.portage.kuroo.actions )
+@@ -139,6 +151,6 @@
+ ########### install ###############
+ install( TARGETS kuroo ${INSTALL_TARGETS_DEFAULT_ARGS} )
+ #install( FILES DESTINATION ${DATA_INSTALL_DIR}/autostart )
+-install( FILES config/kurooconfig.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
++install( FILES config/kurooconfig.kcfg DESTINATION ${KDE_INSTALL_KCFGDIR} )
+ install( FILES kurooui.rc DESTINATION ${KXMLGUI_INSTALL_DIR}/kuroo )
+ install( FILES kuroo.desktop DESTINATION ${XDG_APPS_INSTALL_DIR}/System )
diff --git a/app-portage/kuroo/kuroo-1.2.1.ebuild b/app-portage/kuroo/kuroo-1.2.1.ebuild
index 8924ea2ecde2..c8ec7215a7e3 100644
--- a/app-portage/kuroo/kuroo-1.2.1.ebuild
+++ b/app-portage/kuroo/kuroo-1.2.1.ebuild
@@ -38,6 +38,8 @@ RDEPEND="${DEPEND}
kde-apps/kompare:5
"
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" ) # bug 811693
+
pkg_postinst() {
if ! has_version app-admin/logrotate ; then
elog "Installing app-admin/logrotate is recommended to keep"