summaryrefslogtreecommitdiff
path: root/app-portage/iwdevtools
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/iwdevtools')
-rw-r--r--app-portage/iwdevtools/Manifest4
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.1.1.ebuild36
-rw-r--r--app-portage/iwdevtools/iwdevtools-9999.ebuild8
3 files changed, 44 insertions, 4 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index e7f242976c3e..b5756b23eefb 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1,2 +1,4 @@
-EBUILD iwdevtools-9999.ebuild 886 BLAKE2B a653ad7654670c921e91bdd01cd3e24146735f51445c5edeb1d35559ed2b15f6c175cb20d7a5100626ca7042213e5e7b9bf8a287e71e64793e0d88474d61be60 SHA512 01120583e1719efe44a78a7d495364acd0874f6274335ab64df80b0e916cab812c3da9543d654ebbdb0f205125ff43ffbc65b36baad0f839431f8a7bf8acf632
+DIST iwdevtools-0.1.1.tar.gz 16139 BLAKE2B effceb407319d2f8acf44db5642a55c426c73628bef9c2004dd76118dc042cbc1178975e06b14d6950cef417790693af9a98dc77e4873f0175a408ca14f71384 SHA512 b0d3a1145c3ecfc71e7f8b0d8d8e321840869037841e1faa547ad4a385751b4fb13de31b3ed497eeacbdf227a81c4f28ff6fd229b008105489ada7c1a15b88e4
+EBUILD iwdevtools-0.1.1.ebuild 955 BLAKE2B 62661252672c6a17599ff49885cc27fefb0025444786888941c0900d45e11674884ce940109934b9c0abba2dc5ecd62387c89c148772f28476c9e20717b9cd70 SHA512 ba5cd8d8c7d37529a32d8382986e03d45f295914c9e2545ca7f8358e10ceca276909c41d0a5351085f9316bf389127dd835ba6501e188a9de693fe22983dc93c
+EBUILD iwdevtools-9999.ebuild 934 BLAKE2B 1f360c2597a7bfa117da615743676860d643ae7a4e54b116528a1d4eeefa20829b627af12157c062ed1dca2ea806ad4dd3c9f2ad3597ebd42b769aff224e702f SHA512 5a998419db151b5a0cb46bb23c0374064fc02acf7ce66a84ac64e987a08270842c8786481e890b5356a8652987fcf328978211580d839e051ab62c4db8cc81b2
MISC metadata.xml 353 BLAKE2B f4868e3da19d4f84861e6b6c4dc90bc7e75804eb6d5db4b52992ec3ab9b33e5c4fb44811c8cec56ea5049de90c3ed499795d3b2b402557cf9bd0cb63a4718dcd SHA512 e63ba6b3d19b2ffa64561c986be1fe5094abc27db85c9cc8c71cd2879c1450c44d37370bdce662f0b4295c5d63b8a9dab3088bd645552039ccb76f93b7a0e2d2
diff --git a/app-portage/iwdevtools/iwdevtools-0.1.1.ebuild b/app-portage/iwdevtools/iwdevtools-0.1.1.ebuild
new file mode 100644
index 000000000000..8886d7139126
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-portage/portage-utils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ sys-apps/util-linux"
+
+src_configure() {
+ meson_src_configure -Ddocdir=${PF}
+}
+
+pkg_postinst() {
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "To (optionally) integrate with portage, inspect the .bashrc files installed"
+ elog "at ${EROOT}/usr/share/${PN}. If not already using a bashrc, you can use"
+ elog "the example bashrc directly by creating a symlink:"
+ elog
+ elog " ln -s ../../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ fi
+}
diff --git a/app-portage/iwdevtools/iwdevtools-9999.ebuild b/app-portage/iwdevtools/iwdevtools-9999.ebuild
index 880f2b284b0c..567370192dbf 100644
--- a/app-portage/iwdevtools/iwdevtools-9999.ebuild
+++ b/app-portage/iwdevtools/iwdevtools-9999.ebuild
@@ -14,8 +14,10 @@ SLOT="0"
KEYWORDS=""
RDEPEND="
+ app-misc/pax-utils
app-portage/portage-utils
sys-apps/diffutils
+ sys-apps/file
sys-apps/portage
sys-apps/util-linux"
@@ -25,9 +27,9 @@ src_configure() {
pkg_postinst() {
if [[ ! ${REPLACING_VERSIONS} ]]; then
- elog "To integrate with portage, inspect the .bashrc files installed"
- elog "at ${EROOT}/usr/share/${PN}. If not already using a bashrc, you"
- elog "can use the example bashrc directly by creating a symlink:"
+ elog "To (optionally) integrate with portage, inspect the .bashrc files installed"
+ elog "at ${EROOT}/usr/share/${PN}. If not already using a bashrc, you can use"
+ elog "the example bashrc directly by creating a symlink:"
elog
elog " ln -s ../../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
elog