summaryrefslogtreecommitdiff
path: root/app-portage/iwdevtools/iwdevtools-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/iwdevtools/iwdevtools-9999.ebuild')
-rw-r--r--app-portage/iwdevtools/iwdevtools-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-portage/iwdevtools/iwdevtools-9999.ebuild b/app-portage/iwdevtools/iwdevtools-9999.ebuild
index 567370192dbf..e1cb0aed9c1c 100644
--- a/app-portage/iwdevtools/iwdevtools-9999.ebuild
+++ b/app-portage/iwdevtools/iwdevtools-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit git-r3 meson
+inherit git-r3 meson optfeature
DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
HOMEPAGE="https://github.com/ionenwks/iwdevtools"
@@ -26,6 +26,8 @@ src_configure() {
}
pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
if [[ ! ${REPLACING_VERSIONS} ]]; then
elog "To (optionally) integrate with portage, inspect the .bashrc files installed"
elog "at ${EROOT}/usr/share/${PN}. If not already using a bashrc, you can use"
@@ -33,5 +35,6 @@ pkg_postinst() {
elog
elog " ln -s ../../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for info on tools."
fi
}