summaryrefslogtreecommitdiff
path: root/app-portage/gpyutils/gpyutils-0.4.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gpyutils/gpyutils-0.4.3.ebuild')
-rw-r--r--app-portage/gpyutils/gpyutils-0.4.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-portage/gpyutils/gpyutils-0.4.3.ebuild b/app-portage/gpyutils/gpyutils-0.4.3.ebuild
new file mode 100644
index 000000000000..a519e2a5c0f2
--- /dev/null
+++ b/app-portage/gpyutils/gpyutils-0.4.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utitilies for maintaining Python packages"
+HOMEPAGE="https://github.com/mgorny/gpyutils/"
+SRC_URI="https://github.com/mgorny/gpyutils/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.3.1[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}