summaryrefslogtreecommitdiff
path: root/app-portage/gentoolkit/gentoolkit-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gentoolkit/gentoolkit-9999.ebuild')
-rw-r--r--app-portage/gentoolkit/gentoolkit-9999.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/app-portage/gentoolkit/gentoolkit-9999.ebuild b/app-portage/gentoolkit/gentoolkit-9999.ebuild
index 551b618d223a..5eb3d884baf5 100644
--- a/app-portage/gentoolkit/gentoolkit-9999.ebuild
+++ b/app-portage/gentoolkit/gentoolkit-9999.ebuild
@@ -22,6 +22,8 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage-Tools"
LICENSE="GPL-2"
SLOT="0"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="test"
+RESTRICT="!test? ( test )"
# Need newer Portage for eclean-pkg API, bug #900224
DEPEND="
@@ -44,6 +46,9 @@ BDEPEND="
$(python_gen_cond_dep '
dev-python/setuptools[${PYTHON_USEDEP}]
' python3_12)
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
"
src_prepare() {
@@ -64,6 +69,7 @@ src_configure() {
my_src_configure() {
local emesonargs=(
-Dcode-only=${code_only}
+ $(meson_use test tests)
-Deprefix="${EPREFIX}"
-Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
)