summaryrefslogtreecommitdiff
path: root/app-portage/gentle/gentle-0.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gentle/gentle-0.3.0.ebuild')
-rw-r--r--app-portage/gentle/gentle-0.3.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-portage/gentle/gentle-0.3.0.ebuild b/app-portage/gentle/gentle-0.3.0.ebuild
new file mode 100644
index 000000000000..bd6d5c6e248d
--- /dev/null
+++ b/app-portage/gentle/gentle-0.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=flit
+PYPI_PN="gentle-mxml"
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Gentoo Lazy Entry - a metadata.xml generator"
+HOMEPAGE="
+ https://gentle.sysrq.in
+ https://pypi.org/project/gentle-mxml/
+"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ app-text/xmldiff[${PYTHON_USEDEP}]
+ dev-python/pkginfo[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep \
+ 'dev-python/tomli[${PYTHON_USEDEP}]' 3.10)
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "PKG-INFO support" dev-python/pkginfo
+ optfeature "yaml support" dev-python/pyyaml
+ optfeature "rdf support" dev-python/rdflib
+ optfeature "toml support" dev-python/tomli
+}