summaryrefslogtreecommitdiff
path: root/app-portage/flaggie/flaggie-0.99.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/flaggie/flaggie-0.99.1.ebuild')
-rw-r--r--app-portage/flaggie/flaggie-0.99.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-portage/flaggie/flaggie-0.99.1.ebuild b/app-portage/flaggie/flaggie-0.99.1.ebuild
new file mode 100644
index 000000000000..9ace377582e4
--- /dev/null
+++ b/app-portage/flaggie/flaggie-0.99.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A smart CLI mangler for package.* files"
+HOMEPAGE="
+ https://github.com/projg2/flaggie/
+"
+SRC_URI="
+ https://github.com/projg2/flaggie/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ >=app-portage/gentoopm-0.5.0[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-vcs/git
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ ewarn "This is a preview release of flaggie 1.x. It it not fully featured"
+ ewarn "yet and it may have significant bugs. Please back your /etc/portage"
+ ewarn "up before using it. Verify the results using --pretend."
+}