summaryrefslogtreecommitdiff
path: root/app-portage/elt-patches/elt-patches-20210827.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/elt-patches/elt-patches-20210827.ebuild')
-rw-r--r--app-portage/elt-patches/elt-patches-20210827.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-portage/elt-patches/elt-patches-20210827.ebuild b/app-portage/elt-patches/elt-patches-20210827.ebuild
new file mode 100644
index 000000000000..bc94d8304da6
--- /dev/null
+++ b/app-portage/elt-patches/elt-patches-20210827.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Collection of patches for libtool.eclass"
+HOMEPAGE="https://gitweb.gentoo.org/proj/elt-patches.git/"
+SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~arm64-linux ~ppc64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+
+RDEPEND="sys-apps/gentoo-functions"
+BDEPEND="app-arch/xz-utils"
+
+src_compile() {
+ emake rootprefix="${EPREFIX}" libdirname="$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" rootprefix="${EPREFIX}" install
+}