summaryrefslogtreecommitdiff
path: root/app-pda/ifuse/ifuse-1.1.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/ifuse/ifuse-1.1.3-r1.ebuild')
-rw-r--r--app-pda/ifuse/ifuse-1.1.3-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-pda/ifuse/ifuse-1.1.3-r1.ebuild b/app-pda/ifuse/ifuse-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..9f08c8c83f43
--- /dev/null
+++ b/app-pda/ifuse/ifuse-1.1.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="Mount Apple iPhone/iPod Touch file systems for backup purposes"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=app-pda/libimobiledevice-1.1.4:=
+ >=app-pda/libplist-1.8:=
+ sys-fs/fuse:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOC_CONTENTS="Only use this filesystem driver to create backups of your data.
+The music database is hashed, and attempting to add files will cause the
+iPod/iPhone to consider your database unauthorised.
+It will respond by wiping all media files, requiring a restore through iTunes."
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}