summaryrefslogtreecommitdiff
path: root/app-office
diff options
context:
space:
mode:
Diffstat (limited to 'app-office')
-rw-r--r--app-office/Manifest.gzbin8607 -> 8608 bytes
-rw-r--r--app-office/texmacs/Manifest3
-rw-r--r--app-office/texmacs/texmacs-2.1-r1.ebuild4
-rw-r--r--app-office/texmacs/texmacs-2.1-r100.ebuild62
4 files changed, 66 insertions, 3 deletions
diff --git a/app-office/Manifest.gz b/app-office/Manifest.gz
index d14221deb7db..8c9c449a9ac4 100644
--- a/app-office/Manifest.gz
+++ b/app-office/Manifest.gz
Binary files differ
diff --git a/app-office/texmacs/Manifest b/app-office/texmacs/Manifest
index f45d0e3ab7a4..c85dc6806b92 100644
--- a/app-office/texmacs/Manifest
+++ b/app-office/texmacs/Manifest
@@ -1,3 +1,4 @@
DIST TeXmacs-2.1-src.tar.gz 35851289 BLAKE2B e29cf78d4c0f8b9d8bf89fd448775979efceaecd409c407bf66622cfa0e0aa166fe9a0abc146a282d71d989cdf03b21a8e17545a93196b868190ecb5fff3e993 SHA512 9e33bfb0a74ca6f6947cfa632adc162776083ae5e5ab46bc85fc8dac5e531457a2f888da5e552d6da39db16e543849a7b86f0fc6918b62e911d35ff725e47a2b
-EBUILD texmacs-2.1-r1.ebuild 1319 BLAKE2B b335b29908c7b53c1d9f1eafce0f77cc37717efe7687c6db7a42c1a27b7f029cbe2f97c745a69e5905f037bbe05581583c62082716a284d83bb714bf066ae5ad SHA512 ad9aef6b1614748d8a3a4fe01dd6bc8e385d8d787a08ddedc42f6cb5158e4739360cc3e9ac36f9c80325e056fc0e53882c003e4285cf6924667be320e8e64f1c
+EBUILD texmacs-2.1-r1.ebuild 1322 BLAKE2B 8ac2b134e776afc2a4528b2fc70505e3394d52e3dafa56e9aa34a0d370f998976da159d992995cf405705cc079819c2edee19438221e8d46e6afb131ccdf93da SHA512 b0de1d9188543c379b22f8b1a2fe57799c39408a3b15eeca820c4375ce22039d228626d61ffd7ce2323225109f97caba2a0552b52de72921ff0f10fbc748ad55
+EBUILD texmacs-2.1-r100.ebuild 1366 BLAKE2B c9c11372c3bd1802dcc052338fda6982a7ba26d951071680c6a1f2cd4638cce51760e925c2980764e668437f7df0e3a4cd4490d3cad3e8d0dcebbc0fcb31d303 SHA512 044708fa57a97912978a700163d63c53622b358c0cda6e95a30b39621723aa54c3d4b8aab48f81bd86a9b2d18ef39e8e16a605d8b9ebe16caf4319afb0421d1c
MISC metadata.xml 550 BLAKE2B 6b9e5f132e681b3d4ee67216215e0f884d43b4731082cdda9eb4ad612e49d07172ea33ed1c3efd2576cd0e182673565400956050a8f5601f9df31a316b42fcf4 SHA512 e46f2ac6a80b1890be49363bf094d8500b734dc9e343ed42ed9d7c480f62cee582caf3dd7b36da1507db474279c5fc7b1d8e16294cb85220f28520c5c7e3aae9
diff --git a/app-office/texmacs/texmacs-2.1-r1.ebuild b/app-office/texmacs/texmacs-2.1-r1.ebuild
index c6414ad9d123..882a51c9116f 100644
--- a/app-office/texmacs/texmacs-2.1-r1.ebuild
+++ b/app-office/texmacs/texmacs-2.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,7 +18,7 @@ KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
RDEPEND="
app-text/ghostscript-gpl
- <dev-scheme/guile-1.9[debug?,deprecated]
+ <dev-scheme/guile-1.9:12[debug?,deprecated]
media-libs/freetype
x11-apps/xmodmap
x11-libs/libXext
diff --git a/app-office/texmacs/texmacs-2.1-r100.ebuild b/app-office/texmacs/texmacs-2.1-r100.ebuild
new file mode 100644
index 000000000000..d8397a0264ab
--- /dev/null
+++ b/app-office/texmacs/texmacs-2.1-r100.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GUILE_COMPAT=( 1-8 )
+GUILE_REQ_USE="debug?,deprecated"
+inherit cmake xdg guile-single
+
+MY_P=${P/tex/TeX}-src
+
+DESCRIPTION="Wysiwyg text processor with high-quality maths"
+HOMEPAGE="https://www.texmacs.org/"
+SRC_URI="https://www.texmacs.org/Download/ftp/tmftp/source/${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug jpeg netpbm sqlite svg spell"
+REQUIRED_USE="${GUILE_REQUIRED_USE}"
+
+RDEPEND="
+ ${GUILE_DEPS}
+ app-text/ghostscript-gpl
+ media-libs/freetype
+ x11-apps/xmodmap
+ x11-libs/libXext
+ virtual/latex-base
+ >=dev-qt/qtcore-5.9.1:5
+ >=dev-qt/qtgui-5.9.1:5
+ >=dev-qt/qtwidgets-5.9.1:5
+ >=dev-qt/qtprintsupport-5.9.1:5
+ sqlite? ( dev-db/sqlite )
+ jpeg? ( virtual/imagemagick-tools[jpeg] )
+ netpbm? ( media-libs/netpbm )
+ spell? ( app-text/aspell )
+ svg? ( || ( media-gfx/inkscape gnome-base/librsvg:2 ) )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="x11-base/xorg-proto"
+
+src_prepare() {
+ cmake_src_prepare
+ guile_bump_sources
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SQLITE3=$(usex sqlite 1 0)
+ -DDEBUG_ASSERT=$(usex debug 1 0)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # guile-single_src_install not needed, Guile 1.8 does not have .go
+ # files...
+}