summaryrefslogtreecommitdiff
path: root/app-office/libreoffice/libreoffice-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/libreoffice/libreoffice-9999.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild33
1 files changed, 8 insertions, 25 deletions
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index cb77e652cea2..b334b35d33ee 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -163,7 +163,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
>=media-libs/libvisio-0.1.0
media-libs/libzmf
media-libs/openjpeg:=
- media-libs/zxing-cpp
+ media-libs/zxing-cpp:=
>=net-libs/neon-0.31.1:=
net-misc/curl
sci-mathematics/lpsolve
@@ -237,10 +237,7 @@ DEPEND="${COMMON_DEPEND}
x11-libs/libXtst
java? (
dev-java/ant-core
- || (
- dev-java/openjdk:11
- dev-java/openjdk-bin:11
- )
+ >=virtual/jdk-11
)
test? (
app-crypt/gnupg
@@ -256,11 +253,7 @@ RDEPEND="${COMMON_DEPEND}
!app-office/libreoffice-bin-debug
media-fonts/liberation-fonts
|| ( x11-misc/xdg-utils kde-plasma/kde-cli-tools )
- java? ( || (
- dev-java/openjdk:11
- dev-java/openjdk-jre-bin:11
- >=virtual/jre-1.8
- ) )
+ java? ( >=virtual/jre-11 )
kde? ( kde-frameworks/breeze-icons:* )
"
BDEPEND="
@@ -315,16 +308,10 @@ _check_reqs() {
}
pkg_pretend() {
- if use x86; then
- elog "Unfortunately for packaging reasons on x86, various Java-based wizards,"
- elog "most notably Report Builder in LibreOffice Base, will not be available."
- elog "See also: https://bugs.gentoo.org/785640"
- else
- use base ||
- ewarn "If you plan to use Base application you must enable USE base."
- use java ||
- ewarn "Without USE java, several wizards are not going to be available."
- fi
+ use base ||
+ ewarn "If you plan to use Base application you must enable USE base."
+ use java ||
+ ewarn "Without USE java, several wizards are not going to be available."
[[ ${MERGE_TYPE} != binary ]] && _check_reqs pkg_pretend
}
@@ -568,12 +555,8 @@ src_configure() {
--without-junit
--without-system-hsqldb
--with-ant-home="${ANT_HOME}"
+ --with-jdk-home="${JAVA_HOME}"
)
- if has_version "dev-java/openjdk:11"; then
- myeconfargs+=( --with-jdk-home="${EPREFIX}/usr/$(get_libdir)/openjdk-11" )
- elif has_version "dev-java/openjdk-bin:11"; then
- myeconfargs+=( --with-jdk-home="${EPREFIX}/opt/openjdk-bin-11" )
- fi
use libreoffice_extensions_scripting-beanshell && \
myeconfargs+=( --with-beanshell-jar=$(java-pkg_getjar bsh bsh.jar) )