summaryrefslogtreecommitdiff
path: root/app-office/libreoffice/libreoffice-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/libreoffice/libreoffice-9999.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index ad176ec03f49..567aaa08c52d 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -44,9 +44,8 @@ unset DEV_URI
# These are bundles that can't be removed for now due to huge patchsets.
# If you want them gone, patches are welcome.
ADDONS_SRC=(
- # broken against latest upstream release, too many patches on top:
- # https://github.com/tdf/libcmis/pull/43
- "${ADDONS_URI}/libcmis-0.5.2.tar.xz"
+ # not packaged in Gentoo
+ "${ADDONS_URI}/dragonbox-1.1.3.tar.gz"
# not packaged in Gentoo, https://www.netlib.org/fp/dtoa.c
"${ADDONS_URI}/dtoa-20180411.tgz"
# not packaged in Gentoo, https://skia.org/
@@ -103,7 +102,7 @@ LICENSE="|| ( LGPL-3 MPL-1.1 )"
SLOT="0"
#[[ ${MY_PV} == *9999* ]] || \
-#KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~x86 ~amd64-linux"
+#KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux"
COMMON_DEPEND="${PYTHON_DEPS}
app-arch/unzip
@@ -117,7 +116,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
app-text/libexttextcat
app-text/liblangtag
>=app-text/libmspub-0.1.0
- >=app-text/libmwaw-0.3.1
+ >=app-text/libmwaw-0.3.21
>=app-text/libnumbertext-1.0.6
>=app-text/libodfgen-0.1.0
app-text/libqxp
@@ -128,7 +127,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
app-text/mythes
dev-cpp/abseil-cpp:=
>=dev-cpp/clucene-2.3.3.4-r2
- >=dev-cpp/libcmis-0.5.2
+ >=dev-cpp/libcmis-0.5.2-r2
dev-db/unixODBC
dev-lang/perl
dev-libs/boost:=[nls]
@@ -159,8 +158,10 @@ COMMON_DEPEND="${PYTHON_DEPS}
media-libs/libpagemaker
>=media-libs/libpng-1.4:0=
>=media-libs/libvisio-0.1.0
+ media-libs/libwebp:=
media-libs/libzmf
media-libs/openjpeg:=
+ media-libs/tiff:=
media-libs/zxing-cpp:=
>=net-libs/neon-0.31.1:=
net-misc/curl
@@ -192,6 +193,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
media-libs/gst-plugins-base:1.0
)
gtk? (
+ app-accessibility/at-spi2-core:2
dev-libs/glib:2
dev-libs/gobject-introspection
gnome-base/dconf
@@ -281,7 +283,7 @@ if [[ ${MY_PV} != *9999* ]] && [[ ${PV} != *_* ]]; then
else
# Translations are not reliable on live ebuilds
# rather force people to use english only.
- PDEPEND="!app-office/libreoffice-l10n"
+ RDEPEND+=" !app-office/libreoffice-l10n"
fi
PATCHES=(
@@ -503,8 +505,9 @@ src_configure() {
--with-help="html"
--without-helppack-integration
--with-system-gpgmepp
+ --without-system-dragonbox
--without-system-jfreereport
- --without-system-libcmis
+ --without-system-libfixmath
--without-system-sane
$(use_enable base report-builder)
$(use_enable bluetooth sdremote-bluetooth)