summaryrefslogtreecommitdiff
path: root/app-office/libreoffice/libreoffice-6.2.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/libreoffice/libreoffice-6.2.9999.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-6.2.9999.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/app-office/libreoffice/libreoffice-6.2.9999.ebuild b/app-office/libreoffice/libreoffice-6.2.9999.ebuild
index 0fa4dccc4d59..64438bc0c90a 100644
--- a/app-office/libreoffice/libreoffice-6.2.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-6.2.9999.ebuild
@@ -21,7 +21,7 @@ BRANDING="${PN}-branding-gentoo-0.8.tar.xz"
# PATCHSET="${P}-patchset-01.tar.xz"
[[ ${MY_PV} == *9999* ]] && inherit git-r3
-inherit autotools bash-completion-r1 check-reqs flag-o-matic java-pkg-opt-2 multiprocessing python-single-r1 qmake-utils toolchain-funcs xdg
+inherit autotools bash-completion-r1 check-reqs flag-o-matic java-pkg-opt-2 multiprocessing python-single-r1 qmake-utils toolchain-funcs xdg-utils
DESCRIPTION="A full office productivity suite"
HOMEPAGE="https://www.libreoffice.org"
@@ -283,6 +283,7 @@ pkg_pretend() {
pkg_setup() {
java-pkg-opt-2_pkg_setup
python-single-r1_pkg_setup
+ xdg_environment_reset
[[ ${MERGE_TYPE} != binary ]] && _check_reqs pkg_setup
}
@@ -306,7 +307,7 @@ src_unpack() {
}
src_prepare() {
- xdg_src_prepare
+ default
# sandbox violations on many systems, we don't need it. Bug #646406
sed -i \
@@ -539,7 +540,14 @@ src_install() {
fi
}
-pkg_preinst() {
- java-utils-2_pkg_preinst
- xdg_pkg_preinst
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
}