summaryrefslogtreecommitdiff
path: root/app-office/calcurse/calcurse-4.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/calcurse/calcurse-4.7.1.ebuild')
-rw-r--r--app-office/calcurse/calcurse-4.7.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-office/calcurse/calcurse-4.7.1.ebuild b/app-office/calcurse/calcurse-4.7.1.ebuild
new file mode 100644
index 000000000000..a8060b73a4a8
--- /dev/null
+++ b/app-office/calcurse/calcurse-4.7.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="A text-based calendar and scheduling application"
+HOMEPAGE="https://calcurse.org/"
+SRC_URI="https://calcurse.org/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/httplib2[${PYTHON_USEDEP}]')
+ sys-libs/ncurses:0="
+
+DEPEND="
+ ${RDEPEND}"
+
+# Some tests fail, mostly those pertaining to ical, perhaps due to requiring network?
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.2.1-tinfo.patch
+ "${FILESDIR}"/${PN}-4.7.1-respect-docdir.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+ python_setup
+ python_fix_shebang contrib/caldav/calcurse-caldav
+}
+
+src_install() {
+ # calcurse likes to read the text files uncompressed
+ docompress -x /usr/share/doc
+ default
+}