summaryrefslogtreecommitdiff
path: root/app-mobilephone/scrcpy/scrcpy-1.22.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/scrcpy/scrcpy-1.22.ebuild')
-rw-r--r--app-mobilephone/scrcpy/scrcpy-1.22.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-mobilephone/scrcpy/scrcpy-1.22.ebuild b/app-mobilephone/scrcpy/scrcpy-1.22.ebuild
new file mode 100644
index 000000000000..f0be131a7c94
--- /dev/null
+++ b/app-mobilephone/scrcpy/scrcpy-1.22.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="Display and control your Android device"
+HOMEPAGE="https://github.com/Genymobile/scrcpy"
+# Source code and server part on Android device
+SRC_URI="https://github.com/Genymobile/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/Genymobile/${PN}/releases/download/v${PV}/${PN}-server-v${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="media-libs/libsdl2[X]
+ media-video/ffmpeg
+ virtual/libusb:1"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+src_configure() {
+ local emesonargs=(
+ -Db_lto=true
+ -Dprebuilt_server="${DISTDIR}/${PN}-server-v${PV}"
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+
+ elog "If scrcpy returns an error like"
+ elog ""
+ elog "[server] ERROR: Exception on thread Thread[main,5,main]"
+ elog "java.lang.IllegalArgumentException"
+ elog "at android.media.MediaCodec.native_configure(Native Method)"
+ elog ""
+ elog "Just try with a lower definition:"
+ elog "scrcpy -m 1920 or scrcpy -m 1024"
+}