summaryrefslogtreecommitdiff
path: root/app-mobilephone/scmxx/scmxx-0.9.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/scmxx/scmxx-0.9.0-r1.ebuild')
-rw-r--r--app-mobilephone/scmxx/scmxx-0.9.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-mobilephone/scmxx/scmxx-0.9.0-r1.ebuild b/app-mobilephone/scmxx/scmxx-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..ee5459b3efd1
--- /dev/null
+++ b/app-mobilephone/scmxx/scmxx-0.9.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Exchange data with Siemens phones"
+HOMEPAGE="http://www.hendrik-sattler.de/scmxx/"
+SRC_URI="mirror://sourceforge/scmxx/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="bluetooth nls"
+
+RDEPEND="bluetooth? ( net-wireless/bluez )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+
+ # Clang 16
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ exeinto /usr/lib/scmxx
+ doexe contrib/*
+
+ doman docs/*.1
+
+ rm docs/README_WIN32.txt || die
+ dodoc AUTHORS BUGS CHANGELOG README TODO docs/*.txt
+}