summaryrefslogtreecommitdiff
path: root/app-mobilephone/lightblue/lightblue-0.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/lightblue/lightblue-0.4-r1.ebuild')
-rw-r--r--app-mobilephone/lightblue/lightblue-0.4-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-mobilephone/lightblue/lightblue-0.4-r1.ebuild b/app-mobilephone/lightblue/lightblue-0.4-r1.ebuild
new file mode 100644
index 000000000000..1ddc89fd0cb2
--- /dev/null
+++ b/app-mobilephone/lightblue/lightblue-0.4-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+inherit distutils-r1
+
+DESCRIPTION="API for Python which provides simple access to Bluetooth operations"
+HOMEPAGE="http://lightblue.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+DEPEND="
+ >=dev-libs/openobex-1.3
+ >=dev-python/pybluez-0.9[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}