summaryrefslogtreecommitdiff
path: root/app-misc
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/Manifest.gzbin50071 -> 50222 bytes
-rw-r--r--app-misc/fx/Manifest4
-rw-r--r--app-misc/fx/fx-35.0.0.ebuild37
-rw-r--r--app-misc/fx/metadata.xml11
-rw-r--r--app-misc/spire/Manifest9
-rw-r--r--app-misc/spire/spire-1.11.1.ebuild (renamed from app-misc/spire/spire-1.7.1.ebuild)28
-rw-r--r--app-misc/spire/spire-1.3.3.ebuild54
7 files changed, 71 insertions, 72 deletions
diff --git a/app-misc/Manifest.gz b/app-misc/Manifest.gz
index 3047d0f8e490..4aa28e3e588c 100644
--- a/app-misc/Manifest.gz
+++ b/app-misc/Manifest.gz
Binary files differ
diff --git a/app-misc/fx/Manifest b/app-misc/fx/Manifest
new file mode 100644
index 000000000000..c3b6e86b5773
--- /dev/null
+++ b/app-misc/fx/Manifest
@@ -0,0 +1,4 @@
+DIST fx-35.0.0-deps.tar.xz 14566724 BLAKE2B e1104d78516adcb9346a9a5e12ae6f0289ed08a0476b4a605254301b6a4d47d7b46915fd65dc54f538a388c5c2694027b09af90e0f465f6a5ff84e23a36e7ed7 SHA512 0474627801dbe5de029addc3562827fdc45434dedc8ca33555dfebac9465c315fc3626d600da04362f0fa900132dbb107404b72cdcf4840273a52231f94de4c5
+DIST fx-35.0.0.tar.gz 2666576 BLAKE2B ac2c6b928b04cef596837acbc76df5a835c004b8e726b8f3b9e78e8e4f5e2528f7091a517731d87c51323c67db55f25b118f2870ed57496ed31daf02c066eccf SHA512 3870b52a9b74494369c837041ce3f5dbe668159d5a823fcc4977a3bd348ca54510d346a2c3f78a47fbd6b7999820d819e47e55848da83482bb8f32c8a3ebaf81
+EBUILD fx-35.0.0.ebuild 813 BLAKE2B c7dd749bf7c197a3d679846e2feafc2779e4f6306e997e1a529ad65dd13f9ad81a55142f326a46fd4d108b96b79816e0d7d60a71cc98d70f007ca4feb1984426 SHA512 02b72c86d5ed36531b1d0c5910c043f070d5a4226199e19a00619f8a984ed7013814ce67e1aeedd29b14b5f4f02bcd17ce7ec83570693472e26a2174074e7f5a
+MISC metadata.xml 328 BLAKE2B 8ad2256481a1462af592fda768b219899bcdc33c98028510dc22a241f6078a7dc4b69a07e48e959f4086fb5c741466902bcaaadf35da5341d35e0e74f5344487 SHA512 3fae7e195ba759be6b0a418071e208f786632f79bbd046d7279eb548fc07c9e8c337272f711192d592a595f3ec05bce243acdeb63ff35d4e6583440124b4e777
diff --git a/app-misc/fx/fx-35.0.0.ebuild b/app-misc/fx/fx-35.0.0.ebuild
new file mode 100644
index 000000000000..7c36260ceb59
--- /dev/null
+++ b/app-misc/fx/fx-35.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module shell-completion
+
+DESCRIPTION=" Terminal JSON viewer & processor"
+HOMEPAGE="https://fx.wtf/ https://github.com/antonmedv/fx"
+SRC_URI="https://github.com/antonmedv/fx/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~arthurzam/distfiles/app-misc/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build -o fx .
+
+ mkdir "${T}/comp"
+ ./fx --comp bash > "${T}/comp/fx" || die
+ ./fx --comp zsh > "${T}/comp/_fx" || die
+ ./fx --comp fish > "${T}/comp/fx.fish" || die
+}
+
+src_test() {
+ ego test ./...
+}
+
+src_install() {
+ dobin fx
+ dodoc README.md
+
+ dobashcomp "${T}/comp/fx"
+ dozshcomp "${T}/comp/_fx"
+ dofishcomp "${T}/comp/fx.fish"
+}
diff --git a/app-misc/fx/metadata.xml b/app-misc/fx/metadata.xml
new file mode 100644
index 000000000000..29afbd37a5af
--- /dev/null
+++ b/app-misc/fx/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">antonmedv/fx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/spire/Manifest b/app-misc/spire/Manifest
index 458d7c3a706e..bad3a1c3a7e6 100644
--- a/app-misc/spire/Manifest
+++ b/app-misc/spire/Manifest
@@ -2,13 +2,10 @@ AUX spire-agent.confd 172 BLAKE2B edeab0e043ae0efb94ce7ce6fc6edd57d75de6294a9190
AUX spire-agent.initd 403 BLAKE2B cdac81d4d5aaa7fa1222070c0b287c07299e32c561fd98aed537a734de43bb2d1cf91da26bb2afcd2c88268d2a181e4646ac17c83ec4783ecb188df6ed936258 SHA512 ad538b741a890203c4bf25658ed4957fc434118d2dd56cd8c6e5a4a62a03a595560de5c5139572d641f79308737ebf11449cb87b679aaad55a8654940c28b233
AUX spire-server.confd 176 BLAKE2B 9a0158a8882be40483d6cf5b34b76337064847f86d0afc4a19f12d9a43e13f6075a1c605d6a88cdf9d5012d0aa80ff6a66cb689ab578f6cb24f001dd59b25ca5 SHA512 4f8cde7dcbed2b89b22a565c7c842293061f1de354bf98b863b3551ded32e13342fa3e9efc247f922b463724697a87631950085aa67dc091a9db8600b2f96b05
AUX spire-server.initd 408 BLAKE2B d5e2c8c8af1d27332a6a0762f0795b5a9c9367a95a00ce1eb8e84be06f3bb3201cfed91033ca742ea5ba31477d2bddafb7ee0fdf8e1094d6bc93fe791992a5b4 SHA512 511e3a2bb0baace563504deaf465a64b6ed4b1368afd7b5398357c6a13b1472b29e3da7a9027318a5bc97e3b69561fa24b9d83c022648de24fe5fcc884f93525
-DIST spire-1.3.3-deps.tar.xz 248328956 BLAKE2B 3d07927bad4490c6c87af97cd1c70350c3534993bd907a42b8bd06e31b446f930939e7530d76f771961c07d67f513f2d4f43b1608226701feb21ae18508663e1 SHA512 2d32b2705013f3148a0c26aa77bdf2234233c060b449bcbd73df417e7a9aef254a3fc066cf95b21a03f41cbcf918f23c5d56ad1c83859e8a1360c5a2208bb470
-DIST spire-1.3.3.tar.gz 2426257 BLAKE2B 743a497f37edacd11e21dbd2f89b565b7133d3a098cca9c6fbc0ffd3019b00ac0adac90c68d487fd20aee599a4030aeb03496bb78cd01a5c162cad5087cd8646 SHA512 9417aa53725a893b8b3da59fe8ae15bcbdb650a05dd94065b3ad5d6621a2d2225ef211ed67397094d1b61465d34c1731e4c0d88edd93f6db5ce11f76fad342d6
-DIST spire-1.7.1-deps.tar.xz 435155484 BLAKE2B 90398480e1222960c42cdf0153625f7478ad6c840623dcd40556e0a26c98f5bf24e47af2d47b61f682508c07b9b8d5288499107777efaeb747826bc82a077aae SHA512 da8219000399562770c8c004f0588ada40c45f2d576516e67c958b6c6b4a30b5bbea03986233f5103e66ab1bbe4b9bfb5fb8ef00898b18d4d49ae29f54a7a7a5
-DIST spire-1.7.1.tar.gz 2576518 BLAKE2B af749dd0c26cadfc616658a89a08c99341f527fa090d5c5df76a2a0c258524ede4efc977e2f805cc7be433de0131c69e12c31a6fd2a1b4c5d2d7d3ea43b720d9 SHA512 87979d20074aab358c304de476a6a83aa8f92b0eb8107ab034333934e9bf7067d8015f86fc0b7ff15a015ebe155d74848b6a5ec190e3d72360c45348351f4a10
+DIST spire-1.11.1-deps.tar.xz 115162280 BLAKE2B 090aebb4e3cf4a35a3d568e65ac1fc2acd7df86bb3cfe2e234c8cdb42759bd62cff94dbff46c4960d3eec2f14ee4b8510d45cc4717819bc154c1cdc7e260fe7a SHA512 9f5c2d282723be474ee7e86d15f575af60cc0fa6a15c5f530e41b473eed67ea2cccc706fe9b5d6638e3e4511905b3dcccc03f805b82eb5be70fcc59ae6b16dfe
+DIST spire-1.11.1.tar.gz 3314465 BLAKE2B 86abfb75cc37bf4d6cae3b784b40bf6ac0ae2771acf74fdb682a87fb06469cd5bd18eff431eb645f465a769d8d90ad24b8b32eec8cf910dd413e93fa53c2f236 SHA512 afc7e677b7acc6707d0abd2c422e21a6563291f367d293035c9fdc14ac3332b4983bf71cf670c8c6dbe973c26954ea17f09dc1a0720e720e89d2a06655bd099e
DIST spire-1.8.7-deps.tar.xz 393031212 BLAKE2B 474f17eb65063b059f08ed297c9382aa5c257ed0bf20ae2834bd49bade6c6eba9fc8be75ebf4dc011f8357c8ca223811352fadbd5310fdb28b442aed52425d9f SHA512 78a207b4a1349a8c95c90f4f97404a2484f681c834204f89679377ade2c5b133173bb5faea69099f081e963ea2f7ce11d7c56523ea9ef5569e0b9827d2b3ee95
DIST spire-1.8.7.tar.gz 2628189 BLAKE2B d3aac37fedf0035191dfef58a947b3da7551ba223b351ce575d07e3ff82266be7413b12759d9d2aa238fbd66b30c75922c7e9b341c8c31c7b9b7f6ccef038a2f SHA512 0cf4ea63765cde51356623f365e4d9544fbb2437de846cfb05ad33d9507d4a70379dd9cb0e6e98820deba9cacd2bb6a51af5dff09901fe73c5296a0828269044
-EBUILD spire-1.3.3.ebuild 1402 BLAKE2B 35013f147606eadf81fad470bf76d9303dc87ae0e9068020cb62a9741ed340055e5764fa8b07485b520eefbfb5d9dc8c25c7150e10d599b5ff3d115b23a4c62b SHA512 d1c7b59db95d3c5d56ef34c8645aade4c5333a3c809b9513a8a1b932056e0b05facff4d8cfb737e8614fb8ddb75805d0b04942aca848cc6fef6a3ddfc9f07f1a
-EBUILD spire-1.7.1.ebuild 1546 BLAKE2B 59f31cbb43e040bf9a66dcb6391f3ee6a1e5a3bb44d4b15ca6e2610bbfdd2a3807bf1351425718138918a1f22fdbd8558f914d8c7ca69d264b3c079758830ca1 SHA512 afd3e2e4bef37337f33822fd5e5adb69f827117ba00bc48658d5b30d77f67a1680a5f04fa8981f03037c0e26f7c1512e4f9afadd99678293ff8cbdb357f3097f
+EBUILD spire-1.11.1.ebuild 1582 BLAKE2B 869ac1f1a6197674ddcbe66585220f5d261161dcd3f19a4961557a5f974207db8f0eb8784a4e09a78d705f5ad4b5ff308fc5f1d14a20b8bf6efec3cbde2e4467 SHA512 64cfc3281f963fb19da996054ec3fddfedb753c6f4cd915c9444fd3eb550fa15d2c5c5dc142989362a1bec2f0479ceed7758de8ce2452f7f4c4ab0f1b79900f1
EBUILD spire-1.8.7.ebuild 1547 BLAKE2B 7bdf6fb16ec758d63ec2135791acbb536139b36b79fe7195b10aeff835a76c10f0a5e035f8ebb0a35086ac600e5ed812a248caa5db85877bb5b7a7a4f25a66af SHA512 ceeb687ea53f1df74109217d8d304aa74f3ce5386f239303eb7c1efd86c9c214981219d495587b907bf8bbe931d39eba51526cd37948610450166ef1e8ffa4e8
MISC metadata.xml 326 BLAKE2B 7b7a118d80f01fdf3fb61050463baad127b64405295eb9cdb8d25ed26f5613bd4a783b3672b47989c8fff336cf1892c751350e5e4df887562a4abf211de5fdb6 SHA512 4a762296e3614b2c3abfa4ae6782515185eaaf92e49514fec3562264ac65f35bc9fc51695d5b7e8f71f18ccd55e0be2b18ab49de94a95235303467dec551338c
diff --git a/app-misc/spire/spire-1.7.1.ebuild b/app-misc/spire/spire-1.11.1.ebuild
index 43c7a6704c24..d3b5cd4d4f44 100644
--- a/app-misc/spire/spire-1.7.1.ebuild
+++ b/app-misc/spire/spire-1.11.1.ebuild
@@ -1,26 +1,30 @@
-# Copyright 2019-2023 Gentoo Authors
+# Copyright 2019-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-git_tag=${PV}
-git_hash=1b775d5
+
inherit go-module
+git_hash=32cc98e
+
DESCRIPTION="the spiffe runtime environment"
HOMEPAGE="https://github.com/spiffe/spire"
SRC_URI="https://github.com/spiffe/spire/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+SRC_URI+=" https://dev.gentoo.org/~arthurzam/distfiles/app-misc/${PN}/${P}-deps.tar.xz"
LICENSE="Apache-2.0"
+# Dependent licenses
+LICENSE+=" BSD-2 BSD MIT ISC MPL-2.0"
SLOT="0"
KEYWORDS="~amd64"
-
-COMMON_DEPEND="acct-group/spire
- acct-user/spire"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
-
RESTRICT="test"
+PROPERTIES="test_network"
+
+DEPEND="
+ acct-group/spire
+ acct-user/spire
+"
+RDEPEND="${DEPEND}"
src_compile() {
local go_ldflags+="
@@ -33,7 +37,7 @@ src_compile() {
}
src_test() {
- go test ./... || die "tests failed"
+ ego test ./...
}
src_install() {
@@ -45,7 +49,7 @@ src_install() {
dosym ../../etc/spire /opt/spire/conf
dosym ../../opt/spire/spire-agent /usr/bin/spire-agent
dosym ../../opt/spire/spire-server /usr/bin/spire-server
-dodoc -r doc/*
+ dodoc -r doc/*
newconfd "${FILESDIR}"/spire-agent.confd spire-agent
newinitd "${FILESDIR}"/spire-agent.initd spire-agent
newconfd "${FILESDIR}"/spire-server.confd spire-server
diff --git a/app-misc/spire/spire-1.3.3.ebuild b/app-misc/spire/spire-1.3.3.ebuild
deleted file mode 100644
index 78c6cff9bd21..000000000000
--- a/app-misc/spire/spire-1.3.3.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2019-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module
-
-DESCRIPTION="the spiffe runtime environment"
-HOMEPAGE="https://github.com/spiffe/spire"
-SRC_URI="https://github.com/spiffe/spire/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-COMMON_DEPEND="acct-group/spire
- acct-user/spire"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
-
-src_compile() {
- local targets v
- targets=(
- bin/spire-server
- bin/spire-agent
- bin/k8s-workload-registrar
- bin/oidc-discovery-provider
- )
- v=$(go version | cut -d ' ' -f 3) || die
- v=${v#go}
- emake go_version_full="${v}" "${targets[@]}"
-}
-
-src_test() {
- go test ./... || die "tests failed"
-}
-
-src_install() {
- exeinto /opt/spire
- doexe bin/*
- keepdir /opt/spire/.data
- insinto /etc/spire
- doins -r conf/*
- dosym ../../etc/spire /opt/spire/conf
- dosym ../../opt/spire/spire-agent /usr/bin/spire-agent
- dosym ../../opt/spire/spire-server /usr/bin/spire-server
- newconfd "${FILESDIR}"/spire-agent.confd spire-agent
- newinitd "${FILESDIR}"/spire-agent.initd spire-agent
- newconfd "${FILESDIR}"/spire-server.confd spire-server
- newinitd "${FILESDIR}"/spire-server.initd spire-server
- keepdir /var/log/spire
- fowners spire:spire /opt/spire/.data
- fowners spire:spire /var/log/spire
-}