summaryrefslogtreecommitdiff
path: root/app-misc/workrave
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/workrave')
-rw-r--r--app-misc/workrave/Manifest4
-rw-r--r--app-misc/workrave/files/workrave-1.10.6-automagic-gstreamer.patch23
-rw-r--r--app-misc/workrave/metadata.xml22
-rw-r--r--app-misc/workrave/workrave-1.10.20.ebuild104
4 files changed, 153 insertions, 0 deletions
diff --git a/app-misc/workrave/Manifest b/app-misc/workrave/Manifest
new file mode 100644
index 000000000000..d7f2c4c19bbe
--- /dev/null
+++ b/app-misc/workrave/Manifest
@@ -0,0 +1,4 @@
+AUX workrave-1.10.6-automagic-gstreamer.patch 881 BLAKE2B 9d74d1d51d1f351659b6ce237eb174b193e0dd8f4c1387cc8e5e2e787bc329c86249cd8d06e85c7a101c7edb8c51ae3e94c2dcc3ad565fb0c5699350981138f0 SHA512 87b9ee4847a8d3ed7afd479b0eb67864f328991c76c3525837e8fb31df299dfc5be43ab35c884a75a40f756d1a3b929c6a415448f88cbe726a2088e8cafeb290
+DIST workrave-1.10.20.tar.gz 6377941 BLAKE2B 00f573c05ddacd61d50d80a4079d161b18e7e52606cf502f359cf51c4b64407c978fa944e79314146baea62fe77212fa623d54706c62e23fd1ca17cbf25db409 SHA512 fc8d98aa560946f00ee30be0c28648245a425cd3fddeba8fbdd61fb89d107cc8085d5c4d8a326c739b394e6baada2b28cf98ce9ccaf85dca6bfaa1ae78d4ce56
+EBUILD workrave-1.10.20.ebuild 2747 BLAKE2B cc96842b44fc276753dc4eef8ba6fc1d9cdf1e56e3c0173711eeead52b9883d6e92d4b17e8f273a9744242a0da36c47c710eca75f2dadfcfd70345118fdeb78c SHA512 d09af88807d0b98abcbba41d9943595ca947a217c3d17e106550c94e451e754c8b009dc0014a94134a607185e250879a7548fddd60aaf092ce0bd2ec98ce7202
+MISC metadata.xml 766 BLAKE2B 7fdc6a41af2c9048875b633ed213337c255b0449474d9c3052615655a904406ee35e226b652ca5519d3c12be63550da344eeabad3656604a8c5cb8df0b25fc18 SHA512 980b66185f9d02d4c0cfd2fe24700a4bb325741097ecf63e7bcd7e47c183e4693c22a6486c70dfce2b7d80837de7ab7c9c908f3be12ba5d16bba1de5d61f6858
diff --git a/app-misc/workrave/files/workrave-1.10.6-automagic-gstreamer.patch b/app-misc/workrave/files/workrave-1.10.6-automagic-gstreamer.patch
new file mode 100644
index 000000000000..76c2e67ed607
--- /dev/null
+++ b/app-misc/workrave/files/workrave-1.10.6-automagic-gstreamer.patch
@@ -0,0 +1,23 @@
+--- a/configure.ac.old 2015-10-24 10:11:47.469290574 +0200
++++ b/configure.ac 2015-10-24 10:14:35.918680898 +0200
+@@ -884,20 +884,12 @@
+ if test "x$enable_gstreamer" != "xno";
+ then
+ PKG_CHECK_MODULES([GSTREAMER],
+- [gstreamer-0.10],
+- [config_gstreamer=yes
+- AC_DEFINE(HAVE_GSTREAMER, 1, [Use GStreamer for playing sounds])], [ ])
+-
+- if test "x$config_gstreamer" != "xyes";
+- then
+- PKG_CHECK_MODULES([GSTREAMER],
+ [gstreamer-1.0],
+ [config_gstreamer=yes
+ AC_DEFINE(HAVE_GSTREAMER, 1, [Use GStreamer for playing sounds])],
+ [if test "x$enable_gstreamer" = "xyes"; then
+ AC_MSG_ERROR([GStreamer development headers not found.])
+ fi])
+- fi
+ fi
+
+
diff --git a/app-misc/workrave/metadata.xml b/app-misc/workrave/metadata.xml
new file mode 100644
index 000000000000..a6781d3a5e7c
--- /dev/null
+++ b/app-misc/workrave/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <use>
+ <flag name="mate">Add support for MATE panel</flag>
+ <flag name="xfce">Add support for XFCE panel</flag>
+ </use>
+ <longdescription>
+ Workrave is a program that assists in the recovery and prevention
+ of Repetitive Strain Injury (RSI). The program frequently alerts
+ you to take micro-pauses, rest breaks and restricts you to your
+ daily limit.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">rcaelers/workrave</remote-id>
+ <remote-id type="sourceforge">workrave</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/workrave/workrave-1.10.20.ebuild b/app-misc/workrave/workrave-1.10.20.ebuild
new file mode 100644
index 000000000000..84cbc53fece7
--- /dev/null
+++ b/app-misc/workrave/workrave-1.10.20.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools gnome2 python-single-r1 versionator vcs-snapshot
+
+DESCRIPTION="Helpful utility to attack Repetitive Strain Injury (RSI)"
+HOMEPAGE="http://www.workrave.org/"
+MY_PV=$(replace_all_version_separators '_')
+SRC_URI="https://github.com/rcaelers/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+# dbus support looks to be used only for trying to use panel applets on gnome3!
+IUSE="ayatana doc gnome gstreamer introspection mate nls pulseaudio test xfce"
+REQUIRED_USE="ayatana? ( introspection ) ${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.0:3[introspection?,X]
+ >=dev-cpp/gtkmm-3.18.0:3.0
+ >=dev-cpp/glibmm-2.28.0:2
+ >=dev-libs/libsigc++-2.2.4.2:2
+ ayatana? (
+ >=dev-libs/libdbusmenu-0.4[gtk3,introspection]
+ >=dev-libs/libindicator-0.4:3 )
+ gnome? ( >=gnome-base/gnome-shell-3.6.2 )
+ gstreamer? (
+ media-libs/gstreamer:1.0[introspection?]
+ media-libs/gst-plugins-base:1.0[introspection?]
+ media-plugins/gst-plugins-meta:1.0 )
+ introspection? ( dev-libs/gobject-introspection:= )
+ mate? ( mate-base/mate-applets )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.15 )
+ xfce? (
+ >=x11-libs/gtk+-2.6.0:2[introspection?]
+ >=xfce-base/xfce4-panel-4.4 )
+ x11-libs/libXScrnSaver
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-libs/libXt
+ x11-libs/libXmu
+ ${PYTHON_DEPS}
+"
+# dbus? (
+# >=sys-apps/dbus-1.2
+# dev-libs/dbus-glib )
+
+DEPEND="${RDEPEND}
+ dev-python/cheetah
+ >=dev-util/intltool-0.40.0
+ sys-devel/autoconf-archive
+ x11-base/xorg-proto
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-sgml-utils
+ app-text/xmlto )
+ nls? ( >=sys-devel/gettext-0.17 )
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ vcs-snapshot_src_unpack
+}
+
+src_prepare() {
+ # Fix gstreamer slot automagic dependency, bug #563584
+ # http://issues.workrave.org/show_bug.cgi?id=1179
+ eapply "${FILESDIR}"/${PN}-1.10.6-automagic-gstreamer.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # gnet ("distribution") is dead for ages and other distributions stopped
+ # relying on it for such time too.
+ gnome2_src_configure \
+ --disable-dbus \
+ --disable-distribution \
+ --enable-exercises \
+ --disable-experimental \
+ --disable-gnome2 \
+ --disable-static \
+ --disable-xml \
+ $(use_enable ayatana indicator) \
+ $(use_enable doc manual) \
+ $(use_enable gnome gnome3) \
+ $(use_enable gstreamer) \
+ $(use_enable introspection) \
+ $(use_enable mate) \
+ $(use_enable nls) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable test tests) \
+ $(use_enable xfce)
+}