summaryrefslogtreecommitdiff
path: root/app-misc/wipe
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/wipe')
-rw-r--r--app-misc/wipe/Manifest3
-rw-r--r--app-misc/wipe/files/wipe-2.3.1-musl-stdint.patch21
-rw-r--r--app-misc/wipe/wipe-2.3.1.ebuild13
3 files changed, 29 insertions, 8 deletions
diff --git a/app-misc/wipe/Manifest b/app-misc/wipe/Manifest
index a9881a15d63d..621348b3d162 100644
--- a/app-misc/wipe/Manifest
+++ b/app-misc/wipe/Manifest
@@ -1,4 +1,5 @@
AUX wipe-2.3.1-LDFLAGS.patch 470 BLAKE2B 76b63c80c561bea0fa5bea750b7eae9c6b07b516c6b4ae7b0949fa3e60b2b9c665afb28d48abf5b1c6f6a97062faec16a8f8145a24a461e71cbecb1d67a75b1b SHA512 e44d409f8177466c22c5a76fcb242e424d4584e587c6a8e25c5d3d8adb976b11a5cce2e0a77b99833a06879a4df3bdb2c71e468f08b7c7b2888b5ed1907dbd79
+AUX wipe-2.3.1-musl-stdint.patch 392 BLAKE2B 1316dd67b65ceb3b5816900a00a3bca44346493da8eb18b77da2fd65e4231cf8251bbc3a21c6b182cb9deff0e46fbe7e2d53b7e69b230cfa8a7978046010f54f SHA512 8ccae661f1fa37c143c3c2d6a644bd2bfee4d0ef5a594489592f9f6cad6265774d84cf33c044d13d62a55309bc54093c49b5380006c441804041a47b52be6bce
DIST wipe-2.3.1.tar.bz2 72297 BLAKE2B e4c15e3b2f64d21d05b915af2c841518f686bec297a6b97eb91b57c1af2e5fb70193f54718ca2f9fa9d04ba684ca21f116b75328695e29f757fe44c62c8504e8 SHA512 63870e68fa5dbf90abb686052f8dcc216ccb93b0c4f5cc10d60ccf43f3606ba91b46dc1e3d8b34d201f7ea657f70b45a61d5d04facf5b2a3e47d2286c46e7110
-EBUILD wipe-2.3.1.ebuild 792 BLAKE2B 6f93fee4cc851e862cb3a35a39d27ae66e7cd78221095ce620f2babd641b8d6c6dfd88a493f80cd0aeb316acc00f5b6c8e0306b5471ac1c61deb5e3837e3bb8d SHA512 33d3351e8e5f15481f7c82ca86107d5f97ec6e95ae126cf3f073993223a64b737ed128066446ca5feba1a2ca6834435e7e1de072288e8ff8e6a88f4c80cbdd46
+EBUILD wipe-2.3.1.ebuild 796 BLAKE2B 927cc37a2a3d0cdbbbe8e245884aeca0ce734542f8eba80132b52f4b260e66029558c35eae9cabfbdd02de2a0dd244e8c5fdbc90fa218e220d15a46f6a38d774 SHA512 98c148bda0d54f8daf7fab6d23590d3d33f8c850d42b9245124dce11a1e87960657a47dc892225fb843915345d4c94c37516723aec795fe70f90feb51ba29170
MISC metadata.xml 241 BLAKE2B c8e6466e0c122eda0f737f6830ba6fb7445c0ac7ca1524890b48e927ad302cfdcc7a0852b1d4bc444375dd4f77329345b4a49519833e5638e6a333d3c69015bc SHA512 34af1318b14f520d2aa49e93d44688e907657ffe1d3a6ba4e9f7fbbd00928b427266f836c0eb5efcccba86aaf1e4f49c3e48ab4bedc86334dd207a500a3edc3b
diff --git a/app-misc/wipe/files/wipe-2.3.1-musl-stdint.patch b/app-misc/wipe/files/wipe-2.3.1-musl-stdint.patch
new file mode 100644
index 000000000000..f14c77e09766
--- /dev/null
+++ b/app-misc/wipe/files/wipe-2.3.1-musl-stdint.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/713622
+--- a/rand.h
++++ b/rand.h
+@@ -20,15 +20,9 @@
+ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
+-#ifdef HAVE_STDINT_H
+-# include "stdint.h"
+-#else
+-# ifndef LINUX
+-# define u_int32_t uint32_t
+-# endif
+-#endif
++#include <stdint.h>
+
+-typedef u_int32_t u_rand_t;
++typedef uint32_t u_rand_t;
+
+ #ifndef UINT32_MAX
+ # define UINT32_MAX ULONG_MAX
diff --git a/app-misc/wipe/wipe-2.3.1.ebuild b/app-misc/wipe/wipe-2.3.1.ebuild
index 8775ae458c90..2fd02b71399c 100644
--- a/app-misc/wipe/wipe-2.3.1.ebuild
+++ b/app-misc/wipe/wipe-2.3.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools
@@ -12,12 +12,11 @@ SRC_URI="mirror://sourceforge/wipe/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 x86"
-IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/${P}-LDFLAGS.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-LDFLAGS.patch
+ "${FILESDIR}"/${PN}-2.3.1-musl-stdint.patch
+)
src_prepare() {
default