summaryrefslogtreecommitdiff
path: root/app-misc/wcd/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/wcd/files')
-rw-r--r--app-misc/wcd/files/wcd-5.2.5-gentoo.patch72
-rw-r--r--app-misc/wcd/files/wcd-5.3.4-gentoo.patch67
-rw-r--r--app-misc/wcd/files/wcd-6.0.1-gentoo.patch67
-rw-r--r--app-misc/wcd/files/wcd-6.0.2-gentoo.patch67
4 files changed, 273 insertions, 0 deletions
diff --git a/app-misc/wcd/files/wcd-5.2.5-gentoo.patch b/app-misc/wcd/files/wcd-5.2.5-gentoo.patch
new file mode 100644
index 000000000000..c838e131aa5f
--- /dev/null
+++ b/app-misc/wcd/files/wcd-5.2.5-gentoo.patch
@@ -0,0 +1,72 @@
+ src/Makefile | 20 ++++++++++----------
+ 1 file changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index d4120cc..4505b8d 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -46,12 +46,12 @@ include version.mk
+
+ CC ?= gcc
+ STATIC =
+-STRIP = strip
++STRIP =
+
+ ENABLE_NLS = 1
+
+ PACKAGE = wcd
+-EXT = .exe
++EXT =
+ PROGRAM = $(PACKAGE)$(EXT)
+ BIN = $(PROGRAM)
+
+@@ -188,9 +188,9 @@ endif
+ # possible values: ncurses, curses, pdcurses, pdcursesw or <empty>
+
+ ifdef UCS
+- CURSES = ncursesw
++ CURSES = $(shell pkg-config --libs ncursesw)
+ else
+- CURSES = ncurses
++ CURSES = $(shell pkg-config --libs ncurses)
+ endif
+
+ ifdef CURSES
+@@ -201,7 +201,7 @@ endif
+
+ ifneq (,$(CURSES))
+ DEFS_CURSES = -DWCD_USECURSES
+- LIB_CURSES = -l$(CURSES)
++ LIB_CURSES = $(CURSES)
+ endif
+
+
+@@ -406,15 +406,15 @@ ifdef ASCII_TREE
+ endif
+
+ LDFLAGS_USER =
+-LDFLAGS = $(RPM_OPT_FLAGS) \
++LIBS = $(RPM_OPT_FLAGS) \
+ $(LDFLAGS_EXTRA) \
+ $(NLFLAG) \
+ $(LDFLAG_STATIC) \
+ $(LDFLAGS_USER)
+
+-LIBS = $(LIB_CURSES) \
+- $(LIB_UNISTRING) \
+- $(LIBS_EXTRA)
++LIBS += $(LIB_CURSES) \
++ $(LIB_UNISTRING) \
++ $(LIBS_EXTRA)
+
+ DEFS_USER =
+ DEFS = $(DEF_UNIX) $(DEFS_CURSES) $(EXTRA_DEFS) $(DEFS_USER)
+@@ -470,7 +470,7 @@ status:
+
+ $(BIN): $(OBJS1)
+ $(MAKE) status
+- $(CC) $(OBJS1) $(LDFLAGS) $(LIBS) -o $@
++ $(CC) $(LDFLAGS) $(OBJS1) -o $@ $(LIBS)
+
+ %.o: %.c
+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(DEFS) -c $< -o $@
diff --git a/app-misc/wcd/files/wcd-5.3.4-gentoo.patch b/app-misc/wcd/files/wcd-5.3.4-gentoo.patch
new file mode 100644
index 000000000000..0839bdb069d9
--- /dev/null
+++ b/app-misc/wcd/files/wcd-5.3.4-gentoo.patch
@@ -0,0 +1,67 @@
+--- wcd-5.3.4/src/Makefile
++++ wcd-5.3.4/src/Makefile
+@@ -46,12 +46,12 @@
+
+ CC ?= gcc
+ STATIC =
+-STRIP = strip
++STRIP =
+
+ ENABLE_NLS = 1
+
+ PACKAGE = wcd
+-EXT = .exe
++EXT =
+ PROGRAM = $(PACKAGE)$(EXT)
+ BIN = $(PROGRAM)
+
+@@ -334,9 +334,9 @@
+ # possible values: ncurses, curses, pdcurses, pdcursesw or <empty>
+
+ ifdef UCS
+- CURSES = ncursesw
++ CURSES = $(shell pkg-config --libs ncursesw)
+ else
+- CURSES = ncurses
++ CURSES = $(shell pkg-config --libs ncurses)
+ endif
+
+
+@@ -366,7 +366,7 @@
+
+ ifneq (,$(CURSES))
+ DEFS_CURSES = -DWCD_USECURSES
+- LIB_CURSES = -l$(CURSES)
++ LIB_CURSES = $(CURSES)
+ ifeq (os/2,$(OS))
+ LIB_CURSES += -ltinfo
+ endif
+@@ -456,15 +456,15 @@
+ endif
+
+ LDFLAGS_USER =
+-LDFLAGS = $(RPM_OPT_FLAGS) \
++LIBS = $(RPM_OPT_FLAGS) \
+ $(LDFLAGS_EXTRA) \
+ $(NLFLAG) \
+ $(LDFLAG_STATIC) \
+ $(LDFLAGS_USER)
+
+-LIBS = $(LIB_CURSES) \
+- $(LIB_UNISTRING) \
+- $(LIBS_EXTRA)
++LIBS += $(LIB_CURSES) \
++ $(LIB_UNISTRING) \
++ $(LIBS_EXTRA)
+
+ DEFS_USER =
+ DEFS = $(DEF_UNIX) $(DEFS_CURSES) $(EXTRA_DEFS) $(DEFS_USER)
+@@ -521,7 +521,7 @@
+
+ $(BIN): $(OBJS1)
+ $(MAKE) status
+- $(CC) $(OBJS1) $(LDFLAGS) $(LIBS) -o $@
++ $(CC) $(LDFLAGS) $(OBJS1) -o $@ $(LIBS)
+
+ %.o: %.c
+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(DEFS) -c $< -o $@
diff --git a/app-misc/wcd/files/wcd-6.0.1-gentoo.patch b/app-misc/wcd/files/wcd-6.0.1-gentoo.patch
new file mode 100644
index 000000000000..eca95856ca33
--- /dev/null
+++ b/app-misc/wcd/files/wcd-6.0.1-gentoo.patch
@@ -0,0 +1,67 @@
+--- wcd-6.0.1/src/Makefile
++++ wcd-6.0.1/src/Makefile
+@@ -45,12 +45,12 @@
+
+ CC ?= gcc
+ STATIC =
+-STRIP = strip
++STRIP =
+
+ ENABLE_NLS = 1
+
+ PACKAGE = wcd
+-EXT = .exe
++EXT =
+ PROGRAM = $(PACKAGE)$(EXT)
+ BIN = $(PROGRAM)
+
+@@ -329,9 +329,9 @@
+ # possible values: ncurses, curses, pdcurses, pdcursesw or <empty>
+
+ ifdef UCS
+- CURSES = ncursesw
++ CURSES = $(shell pkg-config --libs ncursesw)
+ else
+- CURSES = ncurses
++ CURSES = $(shell pkg-config --libs ncurses)
+ endif
+
+
+@@ -361,7 +361,7 @@
+
+ ifneq (,$(CURSES))
+ DEFS_CURSES = -DWCD_USECURSES
+- LIB_CURSES = -l$(CURSES)
++ LIB_CURSES = $(CURSES)
+ ifeq (os/2,$(OS))
+ LIB_CURSES += -ltinfo
+ endif
+@@ -455,15 +455,15 @@
+ endif
+
+ LDFLAGS_USER =
+-LDFLAGS = $(RPM_OPT_FLAGS) \
++LIBS = $(RPM_OPT_FLAGS) \
+ $(LDFLAGS_EXTRA) \
+ $(NLFLAG) \
+ $(LDFLAG_STATIC) \
+ $(LDFLAGS_USER)
+
+-LIBS = $(LIB_CURSES) \
+- $(LIB_UNISTRING) \
+- $(LIBS_EXTRA)
++LIBS += $(LIB_CURSES) \
++ $(LIB_UNISTRING) \
++ $(LIBS_EXTRA)
+
+ DEFS_USER =
+ DEFS = $(DEF_UNIX) $(DEFS_CURSES) $(EXTRA_DEFS) $(DEFS_USER)
+@@ -520,7 +520,7 @@
+
+ $(BIN): $(OBJS1)
+ $(MAKE) status
+- $(CC) $(OBJS1) $(LDFLAGS) $(LIBS) -o $@
++ $(CC) $(LDFLAGS) $(OBJS1) -o $@ $(LIBS)
+
+ %.o: %.c
+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(DEFS) -c $< -o $@
diff --git a/app-misc/wcd/files/wcd-6.0.2-gentoo.patch b/app-misc/wcd/files/wcd-6.0.2-gentoo.patch
new file mode 100644
index 000000000000..ecd7c530f156
--- /dev/null
+++ b/app-misc/wcd/files/wcd-6.0.2-gentoo.patch
@@ -0,0 +1,67 @@
+--- wcd-6.0.2/src/Makefile
++++ wcd-6.0.2/src/Makefile
+@@ -45,12 +45,12 @@
+
+ CC ?= gcc
+ STATIC =
+-STRIP = strip
++STRIP =
+
+ ENABLE_NLS = 1
+
+ PACKAGE = wcd
+-EXT = .exe
++EXT =
+ PROGRAM = $(PACKAGE)$(EXT)
+ BIN = $(PROGRAM)
+
+@@ -328,9 +328,9 @@
+ # possible values: ncurses, curses, pdcurses, pdcursesw or <empty>
+
+ ifdef UCS
+- CURSES = ncursesw
++ CURSES = $(shell pkg-config --libs ncursesw)
+ else
+- CURSES = ncurses
++ CURSES = $(shell pkg-config --libs ncurses)
+ endif
+
+
+@@ -360,7 +360,7 @@
+
+ ifneq (,$(CURSES))
+ DEFS_CURSES = -DWCD_USECURSES
+- LIB_CURSES = -l$(CURSES)
++ LIB_CURSES = $(CURSES)
+ ifeq (os/2,$(OS))
+ LIB_CURSES += -ltinfo
+ endif
+@@ -458,15 +458,15 @@
+
+ LDFLAGS_USER =
+ LDFLAGS ?=
+-LDFLAGS += $(RPM_LD_FLAGS) \
++LIBS = $(RPM_LD_FLAGS) \
+ $(LDFLAGS_EXTRA) \
+ $(NLFLAG) \
+ $(LDFLAG_STATIC) \
+ $(LDFLAGS_USER)
+
+-LIBS = $(LIB_CURSES) \
+- $(LIB_UNISTRING) \
+- $(LIBS_EXTRA)
++LIBS += $(LIB_CURSES) \
++ $(LIB_UNISTRING) \
++ $(LIBS_EXTRA)
+
+ DEFS_USER =
+ DEFS = $(DEF_UNIX) $(DEFS_CURSES) $(EXTRA_DEFS) $(DEFS_USER)
+@@ -523,7 +523,7 @@
+
+ $(BIN): $(OBJS1)
+ $(MAKE) status
+- $(CC) $(OBJS1) $(LDFLAGS) $(LIBS) -o $@
++ $(CC) $(LDFLAGS) $(OBJS1) -o $@ $(LIBS)
+
+ %.o: %.c
+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(DEFS) -c $< -o $@