summaryrefslogtreecommitdiff
path: root/app-misc/wally-cli
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/wally-cli')
-rw-r--r--app-misc/wally-cli/Manifest4
-rw-r--r--app-misc/wally-cli/metadata.xml12
-rw-r--r--app-misc/wally-cli/wally-cli-2.0.1.ebuild30
3 files changed, 46 insertions, 0 deletions
diff --git a/app-misc/wally-cli/Manifest b/app-misc/wally-cli/Manifest
new file mode 100644
index 000000000000..995bb74f48c3
--- /dev/null
+++ b/app-misc/wally-cli/Manifest
@@ -0,0 +1,4 @@
+DIST wally-cli-2.0.1-deps.tar.xz 2545464 BLAKE2B 3a1b41d5386e87db69a6d877fcc471cece97e34f913c3b9a4b87ed252f2f79aa335acacc1ffb0706d8a2596b9775ca9fab2d9fc4da9c11f7b8b933e05cb680cb SHA512 45cb90e614031ba674ea384cc829d748f706839b2d928f2e11e268f5991f7704a48f1333f794f4a140c16256cf29f4ee4da05a7a4e0be9107285d2c86a50ca77
+DIST wally-cli-2.0.1.tar.gz 6641 BLAKE2B 876a1e237d08c43b90c89ef596ad9015a6f641d3282296b9e3c846a7bf7fa27988605902deaae9e2c95b9c8bf10a2e2304c3ad5b1812001a45b6ca93eb0210bd SHA512 998035e5d932892245cd6db13682501dc5e65a79b724e9ed66733c955bf6646c46c5cb59214160cd5bc5710949dcd43f054ae72b5adb757aa12e3cece92df4bc
+EBUILD wally-cli-2.0.1.ebuild 637 BLAKE2B 52c3e5cc1f9c53de2687c63d346b317bfa34c62d017b01398912560d5e51ba6c5b1d29151e05ef92a4d6132cb21b4fab9b780e87d534b7d9751d543b5a31f905 SHA512 3cc36aa7c76af41d51e789a00356363ec788c8caebfb76f5c1820af318c347f71033b12ee1e1681fb05e05c6640fd0a85cb47d7c1d2260b271927a5b7a8ac55d
+MISC metadata.xml 393 BLAKE2B 472029d3b4d772794ceddd9c9b3de2afc30dd292ab5340d660c3b50bf6926c4c9879ec020a2f53653f4d21e48357361ee9aff794e37e1f93e11b8babc2816063 SHA512 bbca30599bfe06b4cd8a586eab794f50779d1e284de685d6940eb45e157d40953014dbd8329b6bdae1e311551481561f9a8c0651d389d922813de35d2adc5f59
diff --git a/app-misc/wally-cli/metadata.xml b/app-misc/wally-cli/metadata.xml
new file mode 100644
index 000000000000..c6b4af121f15
--- /dev/null
+++ b/app-misc/wally-cli/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ajak@gentoo.org</email>
+ <name>John Helmert III</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">zsa/wally-cli</remote-id>
+ <changelog>https://github.com/zsa/wally-cli/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/wally-cli/wally-cli-2.0.1.ebuild b/app-misc/wally-cli/wally-cli-2.0.1.ebuild
new file mode 100644
index 000000000000..7f2b088452d9
--- /dev/null
+++ b/app-misc/wally-cli/wally-cli-2.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Flash your ZSA Keyboard the EZ way"
+HOMEPAGE="https://github.com/zsa/wally-cli"
+SRC_URI="https://github.com/zsa/${PN}/archive/refs/tags/${PV}-linux.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~ajak/dist/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+S="${WORKDIR}/${P}-linux"
+
+LICENSE="Apache-2.0 BSD BSD-4 MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( README.md license.md )
+
+DEPEND="dev-libs/libusb:1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ go build
+}
+
+src_install() {
+ default
+ dobin wally-cli
+}