summaryrefslogtreecommitdiff
path: root/app-misc/trash-cli/trash-cli-0.22.8.21.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/trash-cli/trash-cli-0.22.8.21.ebuild')
-rw-r--r--app-misc/trash-cli/trash-cli-0.22.8.21.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/trash-cli/trash-cli-0.22.8.21.ebuild b/app-misc/trash-cli/trash-cli-0.22.8.21.ebuild
new file mode 100644
index 000000000000..641302d9ab3e
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.22.8.21.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="https://github.com/andreafrancia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local -x COLUMNS=80
+ distutils-r1_src_test
+}