summaryrefslogtreecommitdiff
path: root/app-misc/trash-cli/trash-cli-0.20.12.26.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/trash-cli/trash-cli-0.20.12.26.ebuild')
-rw-r--r--app-misc/trash-cli/trash-cli-0.20.12.26.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-misc/trash-cli/trash-cli-0.20.12.26.ebuild b/app-misc/trash-cli/trash-cli-0.20.12.26.ebuild
new file mode 100644
index 000000000000..4c1b99fd98bf
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.20.12.26.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="https://github.com/andreafrancia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests nose