summaryrefslogtreecommitdiff
path: root/app-misc/tmuxp/tmuxp-1.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/tmuxp/tmuxp-1.7.0.ebuild')
-rw-r--r--app-misc/tmuxp/tmuxp-1.7.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-misc/tmuxp/tmuxp-1.7.0.ebuild b/app-misc/tmuxp/tmuxp-1.7.0.ebuild
new file mode 100644
index 000000000000..aab4054c7519
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.7.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ >=dev-python/kaptan-0.5.10[${PYTHON_USEDEP}]
+ >=dev-python/libtmux-0.8.5[${PYTHON_USEDEP}]
+ <dev-python/libtmux-0.9[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ <dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-4.1.1[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/tmuxp-1.6.4-tests.patch"
+ "${FILESDIR}/tmuxp-1.7.0-tests.patch"
+)
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ SHELL="/bin/bash" pytest -vv || die "Tests fail with ${EPYTHON}"
+}