summaryrefslogtreecommitdiff
path: root/app-misc/sphinx/sphinx-2.2.11-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/sphinx/sphinx-2.2.11-r5.ebuild')
-rw-r--r--app-misc/sphinx/sphinx-2.2.11-r5.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-misc/sphinx/sphinx-2.2.11-r5.ebuild b/app-misc/sphinx/sphinx-2.2.11-r5.ebuild
index a12e8f50f0b2..462ddf809f44 100644
--- a/app-misc/sphinx/sphinx-2.2.11-r5.ebuild
+++ b/app-misc/sphinx/sphinx-2.2.11-r5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
#MY_P=${P/_/-}
MY_P=${P}-release
@@ -58,6 +58,10 @@ src_prepare() {
}
src_configure() {
+ # This code is no longer maintained and not compatible with modern C/C++ standards, bug #880923
+ append-cflags -std=gnu89
+ append-cxxflags -std=c++11
+
# fix libiconv detection
use !elibc_glibc && export ac_cv_search_iconv=-liconv