summaryrefslogtreecommitdiff
path: root/app-misc/siglo
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/siglo')
-rw-r--r--app-misc/siglo/Manifest3
-rw-r--r--app-misc/siglo/metadata.xml8
-rw-r--r--app-misc/siglo/siglo-0.9.5.ebuild50
3 files changed, 61 insertions, 0 deletions
diff --git a/app-misc/siglo/Manifest b/app-misc/siglo/Manifest
new file mode 100644
index 000000000000..08b8a3139372
--- /dev/null
+++ b/app-misc/siglo/Manifest
@@ -0,0 +1,3 @@
+DIST siglo-0.9.5.tar.gz 38574 BLAKE2B e593914ab21deaeaaeddafa59545282dfe737e8aa935a53ada444d504499bc03cd1e17f7dca2813d39d30234504742471c2ba2ed94d603c785f7626fa73561fa SHA512 0ed5f9311c680b377c9233dd7db8b00cea3d376933529dadc46c574e12b33a0b9db1b8e1c66fa60dc088a5d0ebb62ac5c1b1b0b00f0e2143ff0f285980938227
+EBUILD siglo-0.9.5.ebuild 1112 BLAKE2B b9311ceaa7028cf7bcdbb2fd9218c3c88c6ed4ddc5aabf6e68ec535c223c0bc3562e1698c78d7e35fec88bb0cf898a9b1bdeec18904c0898229cd501db111115 SHA512 44e692bc830b231b28274cb26211ca91b8ef89c777c3207a6008be559558e15e0d44ff3e18323773179ae0b8e1be99686784e6396979b68df196947b5ba06fd5
+MISC metadata.xml 261 BLAKE2B 36ef7307b8c913ceda7118a783c7f0c263e94e804f7c75e34007573f82dcddf62cfd202716bf5fb6e0adcad28a5a453d516f4caf4d2ca2eed6d076c6f7824afb SHA512 c24567fd3f715c867c52662d520fbf423d407a2a364d4ea9e5e66610cabb3728b494610106110abfac2b36554c4ad4b63f640e92f8d1b22bdea512037e461602
diff --git a/app-misc/siglo/metadata.xml b/app-misc/siglo/metadata.xml
new file mode 100644
index 000000000000..382e03b1550d
--- /dev/null
+++ b/app-misc/siglo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina (Zero_Chaos)</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/siglo/siglo-0.9.5.ebuild b/app-misc/siglo/siglo-0.9.5.ebuild
new file mode 100644
index 000000000000..4f32696ab50e
--- /dev/null
+++ b/app-misc/siglo/siglo-0.9.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_9 )
+inherit gnome2-utils python-single-r1 meson xdg
+
+DESCRIPTION="GTK app to sync InfiniTime watch with PinePhone"
+HOMEPAGE="https://github.com/alexr4535/siglo"
+SRC_URI="https://github.com/alexr4535/siglo/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+DEPEND=""
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/gatt-python[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="${PYTHON_DEPS}"
+
+#tests seem to fail
+RESTRICT="test"
+
+src_configure() {
+ python_setup
+ sed -i "s#python.find_installation('python3').path()#\'${EPYTHON}\'#" src/meson.build
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}/usr/bin"
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}