summaryrefslogtreecommitdiff
path: root/app-misc/selecta/selecta-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/selecta/selecta-9999.ebuild')
-rw-r--r--app-misc/selecta/selecta-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/selecta/selecta-9999.ebuild b/app-misc/selecta/selecta-9999.ebuild
new file mode 100644
index 000000000000..102d07f58dd5
--- /dev/null
+++ b/app-misc/selecta/selecta-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/garybernhardt/selecta"
+else
+ SRC_URI="https://github.com/garybernhardt/selecta/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A fuzzy text selector for files and anything else you need to select"
+HOMEPAGE="https://github.com/garybernhardt/selecta"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ >=dev-lang/ruby-1.9.3"
+
+src_install() {
+ dobin selecta
+ einstalldocs
+}