summaryrefslogtreecommitdiff
path: root/app-misc/rdfind/rdfind-1.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/rdfind/rdfind-1.5.0.ebuild')
-rw-r--r--app-misc/rdfind/rdfind-1.5.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/rdfind/rdfind-1.5.0.ebuild b/app-misc/rdfind/rdfind-1.5.0.ebuild
new file mode 100644
index 000000000000..4754863e9be8
--- /dev/null
+++ b/app-misc/rdfind/rdfind-1.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Find duplicate files based on their content"
+HOMEPAGE="https://github.com/pauldreik/rdfind"
+SRC_URI="https://github.com/pauldreik/rdfind/archive/releases/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-releases-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-libs/nettle:="
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/autoconf-archive"
+
+PATCHES=( "${FILESDIR}/${PN}-1.5.0_include-limits-header.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}