summaryrefslogtreecommitdiff
path: root/app-misc/qcma/qcma-0.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/qcma/qcma-0.4.1.ebuild')
-rw-r--r--app-misc/qcma/qcma-0.4.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/qcma/qcma-0.4.1.ebuild b/app-misc/qcma/qcma-0.4.1.ebuild
new file mode 100644
index 000000000000..865bbcb3f107
--- /dev/null
+++ b/app-misc/qcma/qcma-0.4.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="Cross-platform content manager assistant for the PS Vita"
+HOMEPAGE="https://github.com/codestation/qcma"
+SRC_URI="https://github.com/codestation/qcma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+ffmpeg"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
+ media-libs/vitamtp:0
+ ffmpeg? ( media-video/ffmpeg:0 )
+ x11-libs/libnotify:0
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-qt/linguist-tools
+"
+
+src_prepare() {
+ rm ChangeLog || die "Failed to rm changelog" # Triggers QA warn (symlink to nowhere)
+ default
+}
+
+src_configure() {
+ lrelease common/resources/translations/*.ts
+ eqmake5 PREFIX="${D}"/usr qcma.pro CONFIG+="QT5_SUFFIX" $(usex ffmpeg "" CONFIG+="DISABLE_FFMPEG")
+}