summaryrefslogtreecommitdiff
path: root/app-misc/pal/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/pal/files')
-rw-r--r--app-misc/pal/files/0.4.3-ldflags.patch8
-rw-r--r--app-misc/pal/files/0.4.3-strip.patch17
-rw-r--r--app-misc/pal/files/fix-Wformat-security-errors.patch64
-rw-r--r--app-misc/pal/files/pal-0.4.3-pkg_config.patch14
-rw-r--r--app-misc/pal/files/pal-0.4.3-prefix.patch44
5 files changed, 147 insertions, 0 deletions
diff --git a/app-misc/pal/files/0.4.3-ldflags.patch b/app-misc/pal/files/0.4.3-ldflags.patch
new file mode 100644
index 000000000000..0bfd750ac5e7
--- /dev/null
+++ b/app-misc/pal/files/0.4.3-ldflags.patch
@@ -0,0 +1,8 @@
+--- a/src/Makefile.defs
++++ b/src/Makefile.defs
+@@ -25,4 +25,4 @@
+
+ CFLAGS = ${OPT}
+ CPPFLAGS = ${INCLDIR} ${DEFS}
+-LDFLAGS = ${LIBDIR} ${LIBS}
++LDFLAGS = ${LIBDIR} ${LIBS} ${LDOPT}
diff --git a/app-misc/pal/files/0.4.3-strip.patch b/app-misc/pal/files/0.4.3-strip.patch
new file mode 100644
index 000000000000..b3bfe3fd99f1
--- /dev/null
+++ b/app-misc/pal/files/0.4.3-strip.patch
@@ -0,0 +1,17 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -21,10 +21,10 @@
+ $(NAME): $(OBJ)
+ @echo " [gcc] $(NAME)"
+ @$(CC) $(CFLAGS) $(OBJ) $(LDFLAGS) -o $(NAME)
+-ifneq ($(DEBUG),1)
+- @echo " [strip] $(NAME)"
+- @strip $(NAME)
+-endif
++#ifneq ($(DEBUG),1)
++# @echo " [strip] $(NAME)"
++# @strip $(NAME)
++#endif
+
+
+
diff --git a/app-misc/pal/files/fix-Wformat-security-errors.patch b/app-misc/pal/files/fix-Wformat-security-errors.patch
new file mode 100644
index 000000000000..f1255d9e55f1
--- /dev/null
+++ b/app-misc/pal/files/fix-Wformat-security-errors.patch
@@ -0,0 +1,64 @@
+From 801804d5b1beca5f32dd78cd23e9f9e012ae0420 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Tue, 2 Aug 2016 10:07:39 -0400
+Subject: [PATCH 1/1] src/{input,output}.c: fix -Wformat-security errors.
+
+Newer versions of GCC have the ability to warn about insecure uses of
+format strings. These uses usually involve omitted "%s" format strings
+to the printf() family of functions, and when compiling with
+-Werror=format-security, they can cause the build to fail. This commit
+fixes a few such uses in input.c and output.c
+
+Gentoo-Bug: 521104
+---
+ src/input.c | 4 ++--
+ src/output.c | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/input.c b/src/input.c
+index 79db485..92bad36 100644
+--- a/src/input.c
++++ b/src/input.c
+@@ -463,7 +463,7 @@ static gboolean get_file_to_load(gchar* file, gchar* pal_file, gboolean show_err
+ return FALSE;
+ }
+ else
+- sprintf(pal_file, file);
++ sprintf(pal_file, "%s", file);
+ }
+
+ else
+@@ -618,7 +618,7 @@ GHashTable* load_files()
+ FILE* pal_file_handle = NULL;
+
+ if(!get_file_to_load(settings->pal_file, pal_file, FALSE))
+- sprintf(pal_file, settings->pal_file);
++ sprintf(pal_file, "%s", settings->pal_file);
+
+ pal_file_handle = get_file_handle(pal_file, TRUE);
+ if(pal_file_handle != NULL)
+diff --git a/src/output.c b/src/output.c
+index 97aaa0f..9806089 100644
+--- a/src/output.c
++++ b/src/output.c
+@@ -249,7 +249,7 @@ static void pal_output_text_week(GDate* date, gboolean force_month_label,
+ pal_output_fg(BRIGHT, color, utf8_buf);
+ }
+ else
+- g_print(utf8_buf);
++ g_print("%s", utf8_buf);
+
+
+ if(g_date_compare(date,today) == 0) /* make today bright */
+@@ -270,7 +270,7 @@ static void pal_output_text_week(GDate* date, gboolean force_month_label,
+
+ }
+ else
+- g_print(utf8_buf);
++ g_print("%s", utf8_buf);
+
+
+ /* print extra space between days */
+--
+2.7.3
+
diff --git a/app-misc/pal/files/pal-0.4.3-pkg_config.patch b/app-misc/pal/files/pal-0.4.3-pkg_config.patch
new file mode 100644
index 000000000000..2a299538e999
--- /dev/null
+++ b/app-misc/pal/files/pal-0.4.3-pkg_config.patch
@@ -0,0 +1,14 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -2,9 +2,9 @@
+
+ include Makefile.defs
+
+-INCLDIR = -I${prefix}/include `pkg-config --cflags glib-2.0`
++INCLDIR = -I${prefix}/include $(shell ${PKG_CONFIG} --cflags glib-2.0)
+ LIBDIR =
+-LIBS = `pkg-config --libs glib-2.0` -lreadline -lncurses
++LIBS = $(shell ${PKG_CONFIG} --libs glib-2.0) -lreadline $(shell ${PKG_CONFIG} --libs ncurses)
+
+ SRC = main.c colorize.c output.c input.c event.c rl.c html.c latex.c \
+ add.c edit.c del.c remind.c search.c manage.c
diff --git a/app-misc/pal/files/pal-0.4.3-prefix.patch b/app-misc/pal/files/pal-0.4.3-prefix.patch
new file mode 100644
index 000000000000..08dfba41c7e7
--- /dev/null
+++ b/app-misc/pal/files/pal-0.4.3-prefix.patch
@@ -0,0 +1,44 @@
+--- a/src/Makefile.defs
++++ b/src/Makefile.defs
+@@ -3,7 +3,7 @@
+
+ # directory to install to. Depending on your distribution, you might
+ # want to change this to /usr/local
+-prefix = /usr
++prefix = @GENTOO_PORTAGE_EPREFIX@/usr
+ CC = gcc
+
+ PAL_VERSION = 0.3.5_pre1
+--- a/src/input.c
++++ b/src/input.c
+@@ -567,7 +567,7 @@
+ }
+
+ /* attempt to copy /etc/pal.conf to ~/.pal/pal.conf */
+- file = fopen("/etc/pal.conf", "r");
++ file = fopen("@GENTOO_PORTAGE_EPREFIX@/etc/pal.conf", "r");
+
+ /* if not found, try PREFIX/share/pal/pal.conf instead */
+ /* NOTE: This is will be removed in the future */
+@@ -577,7 +577,7 @@
+
+ if(file == NULL)
+ {
+- pal_output_error(_("ERROR: Can't open file: /etc/pal.conf\n"));
++ pal_output_error(_("ERROR: Can't open file: @GENTOO_PORTAGE_EPREFIX@/etc/pal.conf\n"));
+ pal_output_error(_("ERROR: Can't open file: " PREFIX "/share/pal/pal.conf\n"));
+ pal_output_error(_("ERROR: This indicates an improper installation.\n"));
+ return ht;
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -51,8 +51,8 @@
+ @echo " --- Installing global data --- "
+ @mkdir -p ${DESTDIR}${prefix}/share/pal;
+ install -m 0644 -o root ../share/*.pal ${DESTDIR}${prefix}/share/pal
+- @mkdir -p ${DESTDIR}/etc;
+- install -m 0644 -o root ../pal.conf ${DESTDIR}/etc/
++ @mkdir -p ${DESTDIR}@GENTOO_PORTAGE_EPREFIX@/etc;
++ install -m 0644 -o root ../pal.conf ${DESTDIR}@GENTOO_PORTAGE_EPREFIX@/etc/
+ @echo
+
+ # "install" will install the files needed by pal and also check to see