summaryrefslogtreecommitdiff
path: root/app-misc/mosquitto
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/mosquitto')
-rw-r--r--app-misc/mosquitto/Manifest2
-rw-r--r--app-misc/mosquitto/mosquitto-2.0.12.ebuild121
2 files changed, 123 insertions, 0 deletions
diff --git a/app-misc/mosquitto/Manifest b/app-misc/mosquitto/Manifest
index 92a3c05cc035..2b830e21563e 100644
--- a/app-misc/mosquitto/Manifest
+++ b/app-misc/mosquitto/Manifest
@@ -3,6 +3,8 @@ AUX mosquitto 559 BLAKE2B 16a34850c13d9fd6007b5fbd26b4db9e31caa0ee91b8eee8dbca60
AUX mosquitto.service 261 BLAKE2B 6ea8059914acf8730f2e7d04bfd5f79c59a335b65ddecb4773bb4418260c6ed6d0120eaa2e3f7ba4842fc7014e5b51d1ba376cf1db2009b7a55a53a4e6747221 SHA512 3552618733fc106705375c5a1126db72e356694705312072f27f18e21c142cd75ae3ff1f17854ce54cdee092ff9e01fd75c1a8a12d68f75ead8a3697c69623e9
DIST mosquitto-1.6.15.tar.gz 620117 BLAKE2B 0107ed0af902b84c73b857ccd97dfe96b1c7ed8604b843ad40f62d3f1246ded4ef1691158311ac9a672ca331f569d13547165f3a0386c77e94ddc13c8a9e3e00 SHA512 30fa2e8a15b87a33d6c8fc3a1f5d45d8e15d284fade116ac5b7bc8722609d565bed22ac592c303fc74352e3272067b2b0c8da463abffc6490cf959ce177329f3
DIST mosquitto-2.0.11.tar.gz 760325 BLAKE2B adde701bb87ec8071eaaf74fca37f81c4eae97bf98de0fe471f1dfbfb64ccda15b34611b0ffc3d2099a37994151363ad5c717bfa7695fabc1a4927ebd14ae66e SHA512 d0c7c52cb76c4711e54f841217529326d682c4decfc7a1bc96d872904e68df444ca3918fab7ba041b62f7b5420c89c631227b69a8eec51fd2e2dd480d8244710
+DIST mosquitto-2.0.12.tar.gz 783859 BLAKE2B 3bac953fc7f49e19f1914186044c75d7f8b5b23e656acfb7d4c306740d0add20c08760fc206fc871c5cecf8500eb1c88acc4905bddce159d1e8f0c4e2c28b818 SHA512 acf80980f124073fd2fdd99981bde840654fb40a6b6f1d6ef483e35880b45d029cfa9390a98753de6476f4ade068266cb4c6e3c753a0362c0309a5745ac4ebab
EBUILD mosquitto-1.6.15.ebuild 2828 BLAKE2B 6f7ebe1099d6a6a606bfebf85afec716951aaaff24a3a2e01d7edcdb2f7a4da15496f47aee5282aab37d6b6a663c980217f79aecffd056d4131a1878911c2f3e SHA512 d4bf9db26020f8bd1eb10c8be04fc7201a8afdbfb9e4c52c40d532aaae8e6b3fa3c3636e67631942d9aa02d75adb82314955aa544b5d33fb92b40d4646a87877
EBUILD mosquitto-2.0.11.ebuild 3245 BLAKE2B 2115f6c8466c39726a0cd09dd7c30df93844dd8535952d41735a9161c45039fe464eb7aad021449e805f6b4457ae49f699a55de25dd213aaa68647caee66aab0 SHA512 fc302efff796ef209f81a859a829cd0ef884c805db1943836c04082a91a6c98813e49f64b2b5961560caac31af1ba88679f62d0e004dc2f37cea35bf082c9928
+EBUILD mosquitto-2.0.12.ebuild 3003 BLAKE2B 03654ebea45e113f62551fc4ef87e37be000b98ce7654e5c97f661bb5d6167e1c02bcb8a86e9ddd20067bea94f4a34b519d1184f871bd531194a20d4355b4b84 SHA512 a32d732894e369a4cd7f169a327cd07f89a0bf0a5df93aa59c44d17e0ea746c1dffd431f80bc5868bffc92ca423c75e5cb2018d1360a1557d5a1e163226f5ee2
MISC metadata.xml 611 BLAKE2B d40adc8754f0c20b5c0634b75f12df935d246c67d3a9edccb8db262888b5dd6154fbfc21c270b854e61bb0389c625e3608623dcec519e05badc96f1bbdadf38f SHA512 93161a58861a9ea1ab372495fb66bb695d3be5e59dea96418aaf1f5fad936827d7d65a154711ef8c6c9fc752a69fef20c90741ac2627dfdefb8d38d63a3121fb
diff --git a/app-misc/mosquitto/mosquitto-2.0.12.ebuild b/app-misc/mosquitto/mosquitto-2.0.12.ebuild
new file mode 100644
index 000000000000..ca44457030aa
--- /dev/null
+++ b/app-misc/mosquitto/mosquitto-2.0.12.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-any-r1 systemd toolchain-funcs
+
+DESCRIPTION="An Open Source MQTT v3 Broker"
+HOMEPAGE="https://mosquitto.org/ https://github.com/eclipse/mosquitto"
+SRC_URI="https://mosquitto.org/files/source/${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="bridge examples +persistence +srv ssl tcpd test websockets"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="test? ( bridge )"
+
+RDEPEND="
+ acct-user/mosquitto
+ acct-group/mosquitto
+ dev-libs/cJSON:=
+ srv? ( net-dns/c-ares:= )
+ ssl? (
+ dev-libs/openssl:0=
+ )
+ tcpd? ( sys-apps/tcp-wrappers )"
+
+DEPEND="${PYTHON_DEPS}
+ ${RDEPEND}
+ test? ( dev-util/cunit )
+ websockets? ( net-libs/libwebsockets[lejp] )"
+
+_emake() {
+ local LIBDIR=$(get_libdir)
+ emake \
+ CC="$(tc-getCC)" \
+ CLIENT_LDFLAGS="${LDFLAGS}" \
+ LIB_SUFFIX="${LIBDIR:3}" \
+ WITH_BRIDGE="$(usex bridge)" \
+ WITH_PERSISTENCE="$(usex persistence)" \
+ WITH_SRV="$(usex srv)" \
+ WITH_TLS="$(usex ssl)" \
+ WITH_WEBSOCKETS="$(usex websockets)" \
+ WITH_WRAP="$(usex tcpd)" \
+ "$@"
+}
+
+src_prepare() {
+ default
+ if use persistence; then
+ sed -i -e "/^#autosave_interval/s|^#||" \
+ -e "s|^#persistence false$|persistence true|" \
+ -e "/^#persistence_file/s|^#||" \
+ -e "s|#persistence_location|persistence_location /var/lib/mosquitto/|" \
+ mosquitto.conf || die
+ fi
+
+ # Remove prestripping
+ sed -i -e 's/-s --strip-program=${CROSS_COMPILE}${STRIP}//'\
+ client/Makefile lib/cpp/Makefile src/Makefile lib/Makefile || die
+
+ # Remove failing tests
+ sed -i \
+ -e '/01-connect-575314.py/d' \
+ test/broker/Makefile || die
+ sed -i \
+ -e '/02-subscribe-qos1-async2.test/d' \
+ test/lib/Makefile || die
+
+ # Extend test timeout to prevent spurious failures
+ sed -i -e 's/SUB_TIMEOUT=1/SUB_TIMEOUT=3/' \
+ test/client/test.sh || die
+
+ python_setup
+ python_fix_shebang test
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake test
+}
+
+src_install() {
+ _emake DESTDIR="${D}" prefix=/usr install
+ keepdir /var/lib/mosquitto
+ fowners mosquitto:mosquitto /var/lib/mosquitto
+ dodoc README.md CONTRIBUTING.md ChangeLog.txt
+ doinitd "${FILESDIR}"/mosquitto
+ insinto /etc/mosquitto
+ doins mosquitto.conf
+ insinto /usr/share/mosquitto
+ doins misc/letsencrypt/mosquitto-copy.sh
+ systemd_dounit "${FILESDIR}/mosquitto.service"
+
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+}
+
+pkg_postinst() {
+ for v in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_cut 1 "$v") -lt 2 ]]; then
+ elog
+ elog "Please read the migration guide at:"
+ elog "https://mosquitto.org/documentation/migrating-to-2-0/"
+ elog
+ elog "If you use Lets Encrypt TLS certificates, take note of"
+ elog "the changes required to run the daemon as the unprivileged"
+ elog "mosquitto user. The mosquitto-copy.sh script has been"
+ elog "installed to /usr/share/mosquitto/ for your convenience."
+ elog
+ fi
+ done
+}