summaryrefslogtreecommitdiff
path: root/app-misc/mosquitto
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/mosquitto')
-rw-r--r--app-misc/mosquitto/Manifest2
-rw-r--r--app-misc/mosquitto/mosquitto-2.0.21.ebuild132
2 files changed, 134 insertions, 0 deletions
diff --git a/app-misc/mosquitto/Manifest b/app-misc/mosquitto/Manifest
index 02229153f9b9..a930b7b43a30 100644
--- a/app-misc/mosquitto/Manifest
+++ b/app-misc/mosquitto/Manifest
@@ -1,5 +1,7 @@
AUX mosquitto 559 BLAKE2B 16a34850c13d9fd6007b5fbd26b4db9e31caa0ee91b8eee8dbca605c273756bf6c92458d5093eee56f603cce7f10956ee084403e188d49693a759538976f411f SHA512 0bb0e648484269c2a5396118340177af10fae9ccbe4973371f7c8f5e31c96ff97c5146680415c450bad63397baa5c076e7c994f897fd3af2fcce0d1e0965ee22
AUX mosquitto.notify.service 332 BLAKE2B d11f57574ec2cadd6fdaf87080a81fe19a8a78c9b93bc34b388c55def3a5a4feb214700c63899f3cdd87ddb98ed43079035e8363d3f16a345dd0ca52ec7266c4 SHA512 08514d285c333e24a4f5ebba249a59742cf8ba372d434b022416a87f9f667c9c6ac9c64bc0c4c6624d0ea0665a1d15ba2ec244bf77479f5ee11d954595e06723
DIST mosquitto-2.0.20.tar.gz 799972 BLAKE2B fe1445ff6e2a6869ca911dbc556a2ea3d8826ddfd7dc1c46d6c409a320e58cbae4a3c62f02e3cad96cd2d09d30acd8667e1be2cd197211ca80de2ba782b7c7dc SHA512 4c16ff0ad0e9c6fe5c65ec5a82bef123d9e6490f42658d646e1fad60f098530b7cbbd743460c52d4dec8bc27698c84a557bd539b35ac6c81444539822a544c4c
+DIST mosquitto-2.0.21.tar.gz 804168 BLAKE2B b8afd947dd05293e47d17e1f87186abd7e8719fdcf7e98b680e581bab3d8060e7d43b55421f9a477a797eb17c031523c8282e859f3ff216ded88e022f35e463e SHA512 3acc093ef709c3f0f9d837abbb9e39e4e4ed60488c6180e2da733d65b19107f607c1fb89592d39a14faea531c8689227232e7cb13f3f58cb5ee43dad317c7cd6
EBUILD mosquitto-2.0.20.ebuild 3147 BLAKE2B 713a960c7a586c18a7a5f752a1ca7ccde5ae2ea1a05316f4a125cb05293632e7ebf3c3cbebd7ff2218b73747ee6be541788b01b0b94bed433a3078ea3e558034 SHA512 afab36cbc24ca50c1c5cd10a6caf0e7f99695840bf6dd2590e758560fb5177ffd0e83d794b473f0965d0bf3d00f4cb0fdc45e3db0374043e0f2b69625fffead2
+EBUILD mosquitto-2.0.21.ebuild 3150 BLAKE2B 10e0fced1ad41598070d40027a0a2adc4255569d536d9932b3e302bedade0473de5ca2ad532272229255f16f64893e4ae233646ebc07c809676541653e8cd162 SHA512 87fade39d8e70eb5982f1177c4c7a21aa3cc611cf0a021a4424a0bf2233a064bf914134525ae469bed76b67dd7e32c5d724eca2bc2708157df5898a84178ca90
MISC metadata.xml 612 BLAKE2B 414070cdd858c5fd76b266459ff7b2a66992e8b11e672212f78e366863cd221aa83516a546c69668217a06b087b7b81853fcdff332368355cd1ff8c1292f0c4e SHA512 64242d12473aad0f0d80865da2499679849f6b55f751d27c3cf38e0a5555a305a2cc59f8dfbe4b9d50f0a6b6bc85062b989511c7118045b2c9c3e1e0d1022747
diff --git a/app-misc/mosquitto/mosquitto-2.0.21.ebuild b/app-misc/mosquitto/mosquitto-2.0.21.ebuild
new file mode 100644
index 000000000000..013671f7bf33
--- /dev/null
+++ b/app-misc/mosquitto/mosquitto-2.0.21.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit eapi9-ver python-any-r1 systemd toolchain-funcs
+
+DESCRIPTION="An Open Source MQTT v3 Broker"
+HOMEPAGE="https://mosquitto.org/ https://github.com/eclipse/mosquitto"
+SRC_URI="https://mosquitto.org/files/source/${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+bridge examples +persistence +srv ssl systemd tcpd test websockets"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="test? ( bridge )"
+
+RDEPEND="
+ acct-user/mosquitto
+ acct-group/mosquitto
+ dev-libs/cJSON
+ srv? ( net-dns/c-ares:= )
+ ssl? (
+ dev-libs/openssl:0=
+ )
+ systemd? ( sys-apps/systemd:= )
+ tcpd? ( sys-apps/tcp-wrappers )
+ websockets? ( net-libs/libwebsockets[lejp] )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cunit )
+"
+BDEPEND="
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/psutil[${PYTHON_USEDEP}]')
+ )
+"
+
+python_check_deps() {
+ python_has_version -b "dev-python/psutil[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python_setup
+}
+
+_emake() {
+ local LIBDIR=$(get_libdir)
+ emake \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CLIENT_LDFLAGS="${LDFLAGS}" \
+ LIB_SUFFIX="${LIBDIR:3}" \
+ WITH_BRIDGE="$(usex bridge)" \
+ WITH_PERSISTENCE="$(usex persistence)" \
+ WITH_SRV="$(usex srv)" \
+ WITH_SYSTEMD="$(usex systemd)" \
+ WITH_TLS="$(usex ssl)" \
+ WITH_WEBSOCKETS="$(usex websockets)" \
+ WITH_WRAP="$(usex tcpd)" \
+ "$@"
+}
+
+src_prepare() {
+ default
+ if use persistence; then
+ sed -i -e "/^#autosave_interval/s|^#||" \
+ -e "s|^#persistence false$|persistence true|" \
+ -e "/^#persistence_file/s|^#||" \
+ -e "s|#persistence_location|persistence_location /var/lib/mosquitto/|" \
+ mosquitto.conf || die
+ fi
+
+ # Remove failing tests
+ sed -i \
+ -e '/06-bridge-reconnect-local-out.py/d' \
+ test/broker/Makefile || die
+ sed -i \
+ -e '/02-subscribe-qos1-async2.test/d' \
+ test/lib/Makefile || die
+
+ # Extend test timeout to prevent spurious failures
+ sed -i -e 's/SUB_TIMEOUT=1/SUB_TIMEOUT=3/' \
+ test/client/test.sh || die
+
+ use test && python_fix_shebang test
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake test
+}
+
+src_install() {
+ _emake DESTDIR="${D}" prefix=/usr install
+ keepdir /var/lib/mosquitto
+ fowners mosquitto:mosquitto /var/lib/mosquitto
+ dodoc README.md CONTRIBUTING.md ChangeLog.txt
+ doinitd "${FILESDIR}"/mosquitto
+ insinto /etc/mosquitto
+ doins mosquitto.conf
+ insinto /usr/share/mosquitto
+ doins misc/letsencrypt/mosquitto-copy.sh
+ systemd_newunit "${FILESDIR}/mosquitto.notify.service" mosquitto.service
+
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+}
+
+pkg_postinst() {
+ if ver_replacing -lt 2; then
+ elog
+ elog "Please read the migration guide at:"
+ elog "https://mosquitto.org/documentation/migrating-to-2-0/"
+ elog
+ elog "If you use Lets Encrypt TLS certificates, take note of"
+ elog "the changes required to run the daemon as the unprivileged"
+ elog "mosquitto user. The mosquitto-copy.sh script has been"
+ elog "installed to /usr/share/mosquitto/ for your convenience."
+ elog
+ fi
+}