summaryrefslogtreecommitdiff
path: root/app-misc/mc/mc-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/mc/mc-9999.ebuild')
-rw-r--r--app-misc/mc/mc-9999.ebuild45
1 files changed, 29 insertions, 16 deletions
diff --git a/app-misc/mc/mc-9999.ebuild b/app-misc/mc/mc-9999.ebuild
index 1d3a9867b94d..efb7afe860f7 100644
--- a/app-misc/mc/mc-9999.ebuild
+++ b/app-misc/mc/mc-9999.ebuild
@@ -1,18 +1,16 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+inherit flag-o-matic
+
+MY_P="${P/_/-}"
if [[ ${PV} = *9999* ]]; then
+ inherit autotools git-r3
EGIT_REPO_URI="https://github.com/MidnightCommander/mc.git"
- LIVE_ECLASSES="git-r3 autotools"
- LIVE_EBUILD=yes
-fi
-
-inherit flag-o-matic ${LIVE_ECLASSES}
-
-if [[ -z ${LIVE_EBUILD} ]]; then
- SRC_URI="http://ftp.midnight-commander.org/${P}.tar.xz"
+else
+ SRC_URI="http://ftp.midnight-commander.org/${MY_P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
fi
@@ -21,14 +19,13 @@ HOMEPAGE="https://midnight-commander.org"
LICENSE="GPL-3"
SLOT="0"
-IUSE="+edit gpm nls samba sftp +slang spell test unicode X"
+IUSE="+edit gpm nls sftp +slang spell test unicode X"
REQUIRED_USE="spell? ( edit )"
RDEPEND=">=dev-libs/glib-2.26.0:2
gpm? ( sys-libs/gpm )
kernel_linux? ( sys-fs/e2fsprogs )
- samba? ( net-fs/samba )
sftp? ( net-libs/libssh2 )
slang? ( >=sys-libs/slang-2 )
!slang? ( sys-libs/ncurses:=[unicode(+)?] )
@@ -38,15 +35,18 @@ RDEPEND=">=dev-libs/glib-2.26.0:2
x11-libs/libXau
x11-libs/libXdmcp
x11-libs/libSM )"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
app-arch/xz-utils
virtual/pkgconfig
nls? ( sys-devel/gettext )
test? ( dev-libs/check )
- "
+"
RESTRICT="!test? ( test )"
+S="${WORKDIR}/${MY_P}"
+
pkg_pretend() {
if use slang && use unicode ; then
ewarn "\"unicode\" USE flag only takes effect when the \"slang\" USE flag is disabled."
@@ -56,7 +56,15 @@ pkg_pretend() {
src_prepare() {
default
- [[ -n ${LIVE_EBUILD} ]] && ./autogen.sh
+ if [[ ${PV} == *9999* ]] ; then
+ eautoreconf
+ # taken from autogen.sh script
+ xgettext --keyword=_ --keyword=N_ --keyword=Q_ --output=- \
+ $(find . -name '*.[ch]') | sed -ne '/^#:/{s/#://;s/:[0-9]*/\
+ /g;s/ //g;p;}' | grep -v '^$' | sort | uniq > po/POTFILES.in \
+ || die
+ ./version.sh ${S} || die
+ fi
}
src_configure() {
@@ -73,7 +81,6 @@ src_configure() {
# as it also conflicts with sci-libs/mc: bug #685938
--disable-mclib
$(use_enable nls)
- $(use_enable samba vfs-smb)
$(use_enable sftp vfs-sftp)
$(use_enable spell aspell)
$(use_enable test tests)
@@ -85,6 +92,12 @@ src_configure() {
}
src_test() {
+ # Bug #759466
+ if [[ ${EUID} == 0 ]] ; then
+ ewarn "You are emerging ${PN} as root with 'userpriv' disabled."
+ ewarn "Expect some test failures, or emerge with 'FEATURES=userpriv'!"
+ fi
+
# CK_FORK=no to avoid using fork() in check library
# as mc mocks fork() itself: bug #644462.
#
@@ -94,7 +107,7 @@ src_test() {
}
src_install() {
emake DESTDIR="${D}" install
- dodoc AUTHORS doc/{FAQ,NEWS,README}
+ dodoc AUTHORS NEWS README
# fix bug #334383
if use kernel_linux && [[ ${EUID} == 0 ]] ; then