summaryrefslogtreecommitdiff
path: root/app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild')
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild
index 7b070a25b3a4..65786c991f58 100644
--- a/app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild
+++ b/app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 )
inherit python-single-r1
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
IUSE="python"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
app-text/recode
@@ -41,5 +41,5 @@ src_configure() {
src_install() {
default
- find "${ED}" -name '*.la' -exec rm -f {} +
+ find "${D}" -name '*.la' -type f -delete || die
}