summaryrefslogtreecommitdiff
path: root/app-misc/goobook
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/goobook')
-rw-r--r--app-misc/goobook/Manifest3
-rw-r--r--app-misc/goobook/files/goobook-3.5.1-pyxdg.patch105
-rw-r--r--app-misc/goobook/goobook-3.5.1-r2.ebuild (renamed from app-misc/goobook/goobook-3.5.1-r1.ebuild)10
3 files changed, 114 insertions, 4 deletions
diff --git a/app-misc/goobook/Manifest b/app-misc/goobook/Manifest
index 82c61f6a09f9..d8ae87c5564b 100644
--- a/app-misc/goobook/Manifest
+++ b/app-misc/goobook/Manifest
@@ -1,3 +1,4 @@
+AUX goobook-3.5.1-pyxdg.patch 4669 BLAKE2B 9d1e86d9d2a54b4050378fa0e9799135db6d124b4546393d03981d17dee20d51d47a483075948cb7a9df75f7ab452c11b161db6aa5546bc27509e3b0ce6aad09 SHA512 0ffef1b4710b6b3e6c35d098380b6a3ff7b9b4d77c9b0c651ad5a46aa0491e7feb334bac2c472e11677cf8ae0fe47776abd5ece84efd053ef1fe202f51a37ae3
DIST goobook-3.5.1.tar.gz 38176 BLAKE2B 99a068256ca83e800a2d2e82c88adba85797107dc72edde9fbb3c9790ef38fff627b4db64c21baff14aa8a4c69788c29aeb01dae60533c7f389352aee9401e9c SHA512 58d056d7d76843bc874e55424912bb00068541e674b780511b7753da31f2df9514baa188017dd0a7479b5527cd50c47e35f37afc493bdc973e0eb1624998a611
-EBUILD goobook-3.5.1-r1.ebuild 1173 BLAKE2B cc3747e45d19ea46e390031c0566c415b0f571134c420755bfe3576d0cb25615e83ac1ff02c65348c658ed395ed892d34b64d3de9d6d2b0b01984d8388b8dae0 SHA512 1a588455d84feb5184631a44d700ef2c40f1b12b787a25c3b62e09f4ddfd8461ba738a7c6756717e600a647ff1ba641572f77e5af06b26ce448b8eb1786c3b5f
+EBUILD goobook-3.5.1-r2.ebuild 1245 BLAKE2B ea0eb9440ed45ff52b3a38e50e49c4ed58ffbf136c0813337986111cd9b844f0436e36e051b5734c8d918de5b689fb4ba74169672cf1feb68e7455efda95113f SHA512 b37c05591154dc76051509abd8549756d4bf5cd2d14e6d07bde00940c3e10e375e20295990b2a9bed9ebe7af38b13860482d55e841d3fc7b302cd4d9537a6de2
MISC metadata.xml 508 BLAKE2B d90b6c0e591cc65d70190075968d6c327ed9490109cef726277a42ec2064c5ceb235983ecceb00e28825fcc32318e81745042f29b8e055e7df2139c7fa5f4553 SHA512 ea905765abcb6bfdc1e782ee4addcad84ca275744a0a1793ef3e77a96e0dea3f254a61f39f6b398b1dd338bb1c80c010fcb7b70df8abf4bcdebc4c06410dea93
diff --git a/app-misc/goobook/files/goobook-3.5.1-pyxdg.patch b/app-misc/goobook/files/goobook-3.5.1-pyxdg.patch
new file mode 100644
index 000000000000..e40bc051295f
--- /dev/null
+++ b/app-misc/goobook/files/goobook-3.5.1-pyxdg.patch
@@ -0,0 +1,105 @@
+From 391c081199f9cba5026460fbffba43c03602fa13 Mon Sep 17 00:00:00 2001
+From: Jan Baier <jbaier@suse.cz>
+Date: Mon, 22 Mar 2021 15:04:38 +0100
+Subject: [PATCH] Switch from xdg to pyxdg
+
+As both of them provides the xdg and cannot be installed at the same
+time, pyxdg should be used as it is older, has more features (xdg is a
+subset of pyxdg) and is more used. This change should resolve conflicts
+like https://github.com/srstevenson/xdg/issues/35
+
+Fixes #96
+---
+ CHANGES.rst | 6 ++++++
+ Pipfile | 2 +-
+ goobook/config.py | 16 ++++++++--------
+ setup.py | 4 ++--
+ 4 files changed, 17 insertions(+), 11 deletions(-)
+
+diff --git a/goobook/config.py b/goobook/config.py
+index c948469..05589b1 100644
+--- a/goobook/config.py
++++ b/goobook/config.py
+@@ -10,7 +10,7 @@ import configparser
+ import logging
+
+ import oauth2client.client
+-import xdg
++from xdg import BaseDirectory
+
+ from goobook.storage import Storage
+
+@@ -61,8 +61,8 @@ def read_config(config_file=None):
+ if config_file: # config file explicitly given on the commandline
+ config_file = os.path.expanduser(config_file)
+ else: # search for goobookrc in XDG dirs and homedir
+- config_files = [dir_ / "goobookrc" for dir_ in [xdg.XDG_CONFIG_HOME] +
+- xdg.XDG_CONFIG_DIRS] + [LEGACY_CONFIG_FILE]
++ config_files = [dir_ / "goobookrc" for dir_ in [pathlib.Path(BaseDirectory.xdg_config_home)] +
++ [pathlib.Path(p) for p in BaseDirectory.xdg_config_dirs]] + [LEGACY_CONFIG_FILE]
+ log.debug("config file search path: %s", config_files)
+ for config_file_ in config_files:
+ if config_file_.exists():
+@@ -93,7 +93,7 @@ def read_config(config_file=None):
+ if config.cache_filename: # If explicitly specified in config file
+ config.cache_filename = realpath(expanduser(config.cache_filename))
+ else: # search for goobook_cache in XDG dirs and homedir
+- cache_files = [xdg.XDG_CACHE_HOME / "goobook_cache", LEGACY_CACHE_FILE]
++ cache_files = [pathlib.Path(BaseDirectory.xdg_cache_home) / "goobook_cache", LEGACY_CACHE_FILE]
+ log.debug("cache file search path: %s", cache_files)
+ for cache_file in cache_files:
+ cache_file = cache_file.resolve()
+@@ -101,7 +101,7 @@ def read_config(config_file=None):
+ log.debug("found cache file: %s", cache_file)
+ break
+ else: # If there is none, create in XDG_CACHE_HOME
+- cache_file = xdg.XDG_CACHE_HOME / "goobook_cache"
++ cache_file = pathlib.Path(BaseDirectory.xdg_cache_home) / "goobook_cache"
+ log.debug("no cache file found, will use %s", cache_file)
+ config.cache_filename = str(cache_file)
+
+@@ -110,8 +110,8 @@ def read_config(config_file=None):
+ config.oauth_db_filename = realpath(expanduser(config.oauth_db_filename))
+ auth_file = pathlib.Path(config.oauth_db_filename)
+ else: # search for goobook_auth.json in XDG dirs and homedir
+- auth_files = [dir_ / "goobook_auth.json" for dir_ in [xdg.XDG_DATA_HOME] +
+- xdg.XDG_DATA_DIRS] + [LEGACY_AUTH_FILE]
++ auth_files = [dir_ / "goobook_auth.json" for dir_ in [pathlib.Path(BaseDirectory.xdg_data_home)] +
++ [pathlib.Path(p) for p in BaseDirectory.xdg_data_dirs]] + [LEGACY_AUTH_FILE]
+ log.debug("auth file search path: %s", auth_files)
+ for auth_file in auth_files:
+ auth_file = auth_file.resolve()
+@@ -119,7 +119,7 @@ def read_config(config_file=None):
+ log.debug("found auth file: %s", auth_file)
+ break
+ else: # If there is none, create in XDG_DATA_HOME
+- auth_file = xdg.XDG_DATA_HOME / "goobook_auth.json"
++ auth_file = pathlib.Path(BaseDirectory.xdg_data_home) / "goobook_auth.json"
+ log.debug("no auth file found, will use %s", auth_file)
+ config.oauth_db_filename = str(auth_file)
+
+diff --git a/setup.py b/setup.py
+index e2bed5c..4a6c764 100755
+--- a/setup.py
++++ b/setup.py
+@@ -12,7 +12,7 @@ NEWS = open(os.path.join(HERE, 'CHANGES.rst')).read()
+
+ setuptools.setup(
+ name='goobook',
+- version='3.5.1',
++ version='3.6',
+ description='Search your google contacts from the command-line or mutt.',
+ long_description=README + '\n\n' + NEWS,
+ long_description_content_type="text/x-rst",
+@@ -39,7 +39,7 @@ setuptools.setup(
+ 'google-api-python-client>=1.7.12',
+ 'simplejson>=3.16.0',
+ 'oauth2client>=1.5.0,<5.0.0dev',
+- 'xdg>=4.0.1'
++ 'pyxdg>=0.26'
+ ],
+ extras_require={
+ },
+--
+GitLab
+
diff --git a/app-misc/goobook/goobook-3.5.1-r1.ebuild b/app-misc/goobook/goobook-3.5.1-r2.ebuild
index 6ea38b8a97ef..93031a16eb17 100644
--- a/app-misc/goobook/goobook-3.5.1-r1.ebuild
+++ b/app-misc/goobook/goobook-3.5.1-r2.ebuild
@@ -3,8 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1 readme.gentoo-r1
DESCRIPTION="Access your Google contacts from the command line"
@@ -20,7 +19,12 @@ RDEPEND="
>=dev-python/simplejson-3.16.0[${PYTHON_USEDEP}]
>=dev-python/oauth2client-1.5.0[${PYTHON_USEDEP}]
<dev-python/oauth2client-5[${PYTHON_USEDEP}]
- dev-python/xdg[${PYTHON_USEDEP}]"
+ dev-python/pyxdg[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ # https://gitlab.com/goobook/goobook/-/merge_requests/13
+ "${FILESDIR}"/${P}-pyxdg.patch
+)
DISABLE_AUTOFORMATTING=1
DOC_CONTENTS="