summaryrefslogtreecommitdiff
path: root/app-misc/gnote
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/Manifest4
-rw-r--r--app-misc/gnote/gnote-46.0.ebuild64
-rw-r--r--app-misc/gnote/gnote-46.1.ebuild64
3 files changed, 132 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
index 9a5d00fcca54..0dd4f33f3256 100644
--- a/app-misc/gnote/Manifest
+++ b/app-misc/gnote/Manifest
@@ -1,3 +1,7 @@
DIST gnote-45.2.tar.xz 3248256 BLAKE2B ab687802aa6046556c579f1a11fb807398e69f2a256a8a63f50ea76bbcdfc8708ead603f25274b678912bb567c45e96bfe708ea2d56f9733ee1e6061195826bf SHA512 5380a50cfbf235b0007c47c3a1f4860ade599789e1746a7741fc672265698bb0717858bb39e5c0612d4d4e13040f1865674ddeda1427a4818aff508ba5ce8059
+DIST gnote-46.0.tar.xz 3414728 BLAKE2B c53c4f1b5fa1c1dc0105f52736913ef3562a95e324fe4693e4b2729d5cc3ce47ab97ab8c22e2edb124a7cdd94c735b2b8417a02f88a9c23a310a027452fe8c3d SHA512 a56557ed1d5adb3d5416d8032218c953204737dd813e09c13875a084fd579145f94470b61d8c2322d01dba06ad0bb26d553e5009f5d3e10db284afc8b42e0b79
+DIST gnote-46.1.tar.xz 3414768 BLAKE2B cd0c942d97c06a275bce1dd6317ee4135ba8ea692b39d812de2c057ad2cb523965a701b62214d57c07bb7097293d5e946b19bd98d4629e98df42f13821afa27d SHA512 222cff949bb4403a4004210576d8f141fe4ee811da1ec8ca26a6d5474b4ec6d0fe49f9a8c8952e1228d200ca3b5c3e0eab18efb6787dda8d60608254c47d06a9
EBUILD gnote-45.2.ebuild 1439 BLAKE2B 91c1ac5e65a8ace5485af39981af020d3a948aa2e848b2f4b0b6ea25a978523706c0fe92add93bd4391b0d09dd923a34a0039570fdd009e51a1937b2404199ae SHA512 8a333602a7693217dad23efc085f459fcddd4832d58d17e1a7b3655d8d947320731ddb4861185b6cb2632643c3eda439e232b537d507151257bd9dbf774b5482
+EBUILD gnote-46.0.ebuild 1470 BLAKE2B 6d7156980e5005a47cd6b81100d2a4e820ae5478f212b6018a6bcf22387527c15b6df6be7e913a49a8d7447d492ac3d50fc81070336adfa6a6c6408b48272775 SHA512 5ab134dfa4e35a630d517cf2fe99cc82035de271c27db93485578349f66af2275ef1fbb5e47d8cf2499f7eb22001d56a33a63967517856eac4871ebd152e87f9
+EBUILD gnote-46.1.ebuild 1470 BLAKE2B 6d7156980e5005a47cd6b81100d2a4e820ae5478f212b6018a6bcf22387527c15b6df6be7e913a49a8d7447d492ac3d50fc81070336adfa6a6c6408b48272775 SHA512 5ab134dfa4e35a630d517cf2fe99cc82035de271c27db93485578349f66af2275ef1fbb5e47d8cf2499f7eb22001d56a33a63967517856eac4871ebd152e87f9
MISC metadata.xml 346 BLAKE2B dd5d67f5f5f2bd3205f8087ee8abab196289213b451493bcb0e059f902482449329bf03e9cd44e13cb72a347b4ee97f6b1cdf771c0723bcb93b06dcda9a3cb00 SHA512 0f177f3c20fb7215c21a2df360abfdab37bac8cc8b1405d31cd76d552d65661762a929972b0bed0a4c46b7f9c4b053b9a544209282db688699208b5ba0ccec64
diff --git a/app-misc/gnote/gnote-46.0.ebuild b/app-misc/gnote/gnote-46.0.ebuild
new file mode 100644
index 000000000000..80e0527a52d9
--- /dev/null
+++ b/app-misc/gnote/gnote-46.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 meson readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.74:2[dbus]
+ >=dev-cpp/glibmm-2.74:2.68
+ >=dev-cpp/gtkmm-4.10.0:4.0
+ >=gui-libs/libadwaita-1
+ >=app-crypt/libsecret-0.8
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16
+ test? ( dev-libs/unittest++ )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Build system requires UnitTest++ >=1.5.1, but the .pc file doesn't
+ # specify a version
+ sed -i -e "/UnitTest++/ s/version: [^,]*,//" meson.build || die
+ if ! use test; then
+ sed -i -e "/unit_test_pp/ s/ = .*/ = disabler()/" meson.build || die
+ fi
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/app-misc/gnote/gnote-46.1.ebuild b/app-misc/gnote/gnote-46.1.ebuild
new file mode 100644
index 000000000000..80e0527a52d9
--- /dev/null
+++ b/app-misc/gnote/gnote-46.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 meson readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.74:2[dbus]
+ >=dev-cpp/glibmm-2.74:2.68
+ >=dev-cpp/gtkmm-4.10.0:4.0
+ >=gui-libs/libadwaita-1
+ >=app-crypt/libsecret-0.8
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16
+ test? ( dev-libs/unittest++ )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Build system requires UnitTest++ >=1.5.1, but the .pc file doesn't
+ # specify a version
+ sed -i -e "/UnitTest++/ s/version: [^,]*,//" meson.build || die
+ if ! use test; then
+ sed -i -e "/unit_test_pp/ s/ = .*/ = disabler()/" meson.build || die
+ fi
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}