summaryrefslogtreecommitdiff
path: root/app-misc/fastfetch/files/fastfetch-2.0.0-dont-fetch-yyjson.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/fastfetch/files/fastfetch-2.0.0-dont-fetch-yyjson.patch')
-rw-r--r--app-misc/fastfetch/files/fastfetch-2.0.0-dont-fetch-yyjson.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/fastfetch/files/fastfetch-2.0.0-dont-fetch-yyjson.patch b/app-misc/fastfetch/files/fastfetch-2.0.0-dont-fetch-yyjson.patch
new file mode 100644
index 000000000000..e235cf3a6f00
--- /dev/null
+++ b/app-misc/fastfetch/files/fastfetch-2.0.0-dont-fetch-yyjson.patch
@@ -0,0 +1,31 @@
+fastfetch 2.0.0 tries to fetch yyjson at build time.
+
+This is not allowed in Gentoo.
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -36,24 +36,6 @@
+
+ include(CheckIncludeFile)
+
+-include(FetchContent)
+-function(ff_fetch_dep package repo tag)
+- FetchContent_Declare(
+- "${package}"
+- GIT_REPOSITORY "${repo}"
+- GIT_TAG "${tag}"
+- GIT_PROGRESS TRUE
+- )
+- FetchContent_GetProperties("${package}")
+- if(NOT ${package}_POPULATED)
+- message("-- Fetching dependency ${package}@${tag} from ${repo}")
+- FetchContent_Populate(${package})
+- add_subdirectory(${${package}_SOURCE_DIR} ${${package}_BINARY_DIR} EXCLUDE_FROM_ALL)
+- endif()
+-endfunction()
+-
+-ff_fetch_dep(yyjson "https://github.com/ibireme/yyjson" "0.7.0")
+-
+ #####################
+ # Configure options #
+ #####################