summaryrefslogtreecommitdiff
path: root/app-misc/empty/empty-0.6.21b.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/empty/empty-0.6.21b.ebuild')
-rw-r--r--app-misc/empty/empty-0.6.21b.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/empty/empty-0.6.21b.ebuild b/app-misc/empty/empty-0.6.21b.ebuild
new file mode 100644
index 000000000000..95c42481ff4f
--- /dev/null
+++ b/app-misc/empty/empty-0.6.21b.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Small shell utility, similar to expect(1)"
+HOMEPAGE="http://empty.sourceforge.net"
+SRC_URI="https://download.sourceforge.net/empty/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/logger"
+
+PATCHES=( "${FILESDIR}/${PN}-respect-LDFLAGS.patch" )
+
+S="${WORKDIR}"
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin empty
+ doman empty.1
+ dodoc README
+ dodoc -r examples
+}