summaryrefslogtreecommitdiff
path: root/app-misc/dfshow/dfshow-0.8.2_beta-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/dfshow/dfshow-0.8.2_beta-r1.ebuild')
-rw-r--r--app-misc/dfshow/dfshow-0.8.2_beta-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/dfshow/dfshow-0.8.2_beta-r1.ebuild b/app-misc/dfshow/dfshow-0.8.2_beta-r1.ebuild
new file mode 100644
index 000000000000..5733b6700512
--- /dev/null
+++ b/app-misc/dfshow/dfshow-0.8.2_beta-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_PV="${PV//_beta/-beta}"
+
+DESCRIPTION="DF-SHOW is a Unix-like rewrite of some of the applications from DF-EDIT"
+HOMEPAGE="https://github.com/roberthawdon/dfshow"
+SRC_URI="https://github.com/roberthawdon/dfshow/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/libconfig:=
+ sys-libs/ncurses:0=
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i 's/LDADD = -lncursesw -lm -lconfig/LDADD = -lncursesw -lm -lconfig -ltinfow/' Makefile.am ||
+ die "sed in Makefile.am failed"
+ eautoreconf
+ eautomake --add-missing
+}