summaryrefslogtreecommitdiff
path: root/app-misc/devtodo/devtodo-0.1.20-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/devtodo/devtodo-0.1.20-r3.ebuild')
-rw-r--r--app-misc/devtodo/devtodo-0.1.20-r3.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/app-misc/devtodo/devtodo-0.1.20-r3.ebuild b/app-misc/devtodo/devtodo-0.1.20-r3.ebuild
index 8e8653c62509..7be802db3607 100644
--- a/app-misc/devtodo/devtodo-0.1.20-r3.ebuild
+++ b/app-misc/devtodo/devtodo-0.1.20-r3.ebuild
@@ -1,12 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-inherit autotools-utils bash-completion-r1 eutils flag-o-matic toolchain-funcs
+inherit autotools bash-completion-r1 flag-o-matic
DESCRIPTION="A nice command line todo list for developers"
HOMEPAGE="http://swapoff.org/DevTodo"
@@ -15,8 +12,8 @@ SRC_URI="http://swapoff.org/files/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
+BDEPEND="virtual/pkgconfig"
RDEPEND="
>=sys-libs/ncurses-5.2:0=
>=sys-libs/readline-4.1:0="
@@ -25,12 +22,16 @@ DEPEND="${RDEPEND}"
DOCS=( AUTHORS ChangeLog QuickStart README doc/scripts.sh doc/scripts.tcsh doc/todorc.example )
PATCHES=(
- "${FILESDIR}"/${P}-gentoo.diff
+ "${FILESDIR}"/${P}-gentoo.patch
"${FILESDIR}"/${P}-gcc43.patch
"${FILESDIR}"/${P}-bashcom_spaces.patch
)
src_prepare() {
+ default
+
+ mv configure.{in,ac} || die
+
# fix regex.h issue on case-insensitive file-systems #332235
sed \
-e 's/Regex.h/DTRegex.h/' \
@@ -41,7 +42,7 @@ src_prepare() {
-e "/^LIBS/s:$: $($(tc-getPKG_CONFIG) --libs ncursesw):g" \
-i src/Makefile.am || die
- autotools-utils_src_prepare
+ eautoreconf
}
src_configure() {
@@ -50,11 +51,12 @@ src_configure() {
local myeconfargs=(
--sysconfdir="${EPREFIX}/etc/devtodo"
)
- autotools-utils_src_configure
+
+ econf "${myeconfargs[@]}"
}
src_install() {
- autotools-utils_src_install
+ default
newbashcomp contrib/${PN}.bash-completion ${PN}
rm contrib/${PN}.bash-completion || die 'rm failed'